Page MenuHomePhabricator

Africa Wikimedia Developer IRC meeting #17
Closed, ResolvedPublic

Description

NOTE: For last meeting and minutes, see here: https://phabricator.wikimedia.org/T220167

When: Friday, 10th May 2019
Time: 4pm - 5:30pm UTC
Where: #wikimedia-dev-africa on Freenode
Hosts: @rosalieper, @samuelguebo, @Flixtey

Meeting Agenda

  • Welcome Intro
  • Overview of GSoC and Outreachy results
  • How to find beginner bugs and fix?
  • Some resources to share
  • How to improve on my coding skills as a volunteer dev?

1DRINGGGGGGGGGGGGGGGGGGGGGG!!!!!!!!!!!!!!!!!
25:00 PM meeting officially starts :)
35:00 PM welcome everyone to the AWMD irc meeting
45:01 PM here we discuss things related to contributions of code to mediawiki code and its extension. or generally to any wikimedia related software
55:02 PM → Eugene233 joined (uid268461@gateway/web/irccloud.com/x-jeqskusprfimxzus)
65:02 PM
7<r054l13> Rosalie Here is our agenda : https://phabricator.wikimedia.org/T220168
85:03 PM if there is no question I move on 👋🏿
95:03 PM great :D
105:04 PM next point =>> Overview of GSoC and Outreachy results
115:05 PM So any accepted student with us today?
125:06 PM AFAICT there was no accepted African in Wikimedia this year but last year we had 2. the results are not very cute but there is some positive change
135:07 PM we had many active students from Africa this year and that's great even if we not selected, we learnt a bunch of new things and stand for better chances in new round
145:07 PM :D
155:08 PM am done for the point. if anyone has something to add, have the floor ....
165:10 PM next point =>>> How to find beginner bugs and fix?
175:11 PM is there somebody with me in this channel ??
185:11 PM
19<didicodes> Didicodes Some from Kenya got accepted for Outreachy
205:11 PM
21<r054l13> Rosalie didicodes: ohhhhhhhhhhhhhh great
225:11 PM love the news
235:11 PM
24<didicodes> Didicodes Yeah
255:11 PM
26<r054l13> Rosalie who is she?
275:11 PM
28<didicodes> Didicodes Jerop Brenda
295:12 PM
30<r054l13> Rosalie 😎 nice news
315:12 PM thanks for the updates
325:12 PM
33<didicodes> Didicodes You are welcome
345:13 PM
35<r054l13> Rosalie I will also like to carry a survey on how many applied this year and what they learnt to have some satistics that could be usefull for improvement
365:14 PM still to suggest the idea to the core team before execution. So no promises for now :)
375:14 PM next point =>>> How to find beginner bugs and fix?
385:15 PM some volunteers have asked manytimes how to find bugs and how to setup to fix them
395:16 PM not sure if they are present now.
405:16 PM This is a good link to search on: https://phabricator.wikimedia.org/maniphest/?project=PHID-PROJ-ufc7ddusqkgkur44zjnw&statuses=open()&group=none&order=newest#R
415:17 PM that is an advanced search form, you build the query by filling the form to get a task suitable for yourself
425:17 PM for beginner task, just add the tag 'good first bug' in the tag field of the form
435:18 PM for tasks specific to a project, add the project tag to the form and search
445:18 PM the above link gives all the tasks under AWMD project
455:18 PM Please any question?
465:19 PM → ammarpad joined (uid365287@gateway/web/irccloud.com/x-nlynwlorlogznlqz)
475:21 PM
48<r054l13> Rosalie once you have results for the search, select one task and read the description
495:21 PM you select by clicking on the task name
505:21 PM results for the search display below the form
515:22 PM → brendajerop joined (~Thunderbi@197.232.61.234)
525:22 PM
53<r054l13> Rosalie if you feel like going in for the task, check the task tags you will see the projects the bug is found in
545:23 PM if you are not sure, leave your question as a comment on the task page(ticket)
555:23 PM someone will help :
565:23 PM :D
575:24 PM once you have the project name, find its documentation on mediawiki.org
585:24 PM and installation instructions
595:25 PM setup your environment and try to reproduce the bug if it is a bug. otherwise start working if it is an improvement
605:26 PM CFisch_remote → CFisch_NA
615:28 PM
62<r054l13> Rosalie if you have questions or difficulties ping anybody you feel can be of help you, could be r054l13, xSavitar, africanhope, Zppix and many more :) or drop your question on any wikimedia channel
635:28 PM #wikimedia-dev-africa and #wikimedia=dev could be a good start
645:29 PM #wikimedia-dev, *
655:29 PM
66<wikibugs> Wikibugs v2.1, https://tools.wmflabs.org/wikibugs/ Pywikibot, Continuous-Integration-Config, Pywikibot-tests, Release-Engineering-Team (Kanban): Magul's quick tests doesn't run anymore - https://phabricator.wikimedia.org/T186208 (hashar) a:hashar→None Despite a first try at looking at pywikibot/core and attempting to run the test suite /...
675:29 PM
68<r054l13> Rosalie Hi brendajerop congratulationsss of your selection
695:29 PM on*
705:30 PM
71<brendajerop> r054l13: Thank you so much
725:31 PM
73<r054l13> Rosalie brendajerop: Feel free to share your project blogs on the mailing list. I will personally love to read them :)
745:32 PM
75<brendajerop> r054l13: Will do :)
765:33 PM
77<r054l13> Rosalie So any one has something to add?
785:33 PM am moving to next point
795:34 PM next point=>>>> Some resources to share
805:36 PM So came acrose some nice opportunities and would like to share them
815:36 PM https://developers.google.com/season-of-docs/
825:37 PM GSoD= Google Season of Docs
835:37 PM Wikimedia is a selected organization for this program
845:37 PM
85<Zppix> r054l13: you pinged me?
865:38 PM
87<r054l13> Rosalie Zppix: yeah but not needing a reply, no worries :)
885:38 PM
89<Zppix> Ok
905:39 PM
91<r054l13> Rosalie If you have some skills in technical writing, contribute to Opensource through GSoD
925:39 PM follow the link I sent above for more information
935:40 PM This may also help :https://developers.googleblog.com/2019/04/advance-your-career-with-google-africa.html
945:41 PM learn how o code under google scholarship.
955:41 PM For those not part of the meeting, I will share the links again on the mailing list
965:42 PM Any Auestions?
975:42 PM Questions*?
985:42 PM aah this keyboard :(
995:43 PM any comment?
1005:44 PM Your comment may still be that 'r054l13 your agenda is great' :D
1015:44 PM
102<Zppix> I smell bias
1035:45 PM
104<r054l13> Rosalie would like to hear from you guys, feels like am alone. but yo can still ignore me if you like
1055:45 PM
106<jenniline> Jenniline Am happy to know the steps to take as a new contributor.
1075:45 PM
108<brendajerop> r054l13: Thank you for the resources. GSoD seems quite interesting
1095:45 PM
110<r054l13> Rosalie Zppix: on what?
1115:46 PM jenniline: niceee
1125:46 PM brendajerop: welcome
1135:46 PM
114<Zppix> r054l13: you saying your agenda is great (i was joking)
1155:46 PM
116<r054l13> Rosalie Zppix: ahh feeling better hahaha
1175:47 PM So next point
1185:47 PM =>>> How to improve on my coding skills as a volunteer dev?
1195:49 PM The reason I included this in the agenda is because I believe many volunteers reason for contributing is to learn and that is good
1205:49 PM ⇐ paulwiki quit (~paulwiki@154.0.26.6) Remote host closed the connection
1215:49 PM
122<r054l13> Rosalie But then how do I(as a volunteer) make that possible?
1235:50 PM Firstly by being active**
1245:51 PM Secondly by being Proactive**
1255:51 PM the 2 walk together
1265:52 PM
127<wikibugs> Wikibugs v2.1, https://tools.wmflabs.org/wikibugs/ (CR) Xqt: [doc] Fix errors and warnings in script_wui.py documentation (1 comment) [pywikibot/core] - https://gerrit.wikimedia.org/r/509432 (https://phabricator.wikimedia.org/T187009) (owner: Dvorapa)
1285:52 PM
129<r054l13> Rosalie you won't learn much if you always in your conner looking at things hapening. contribute, make sugestions, volunteer for TODOs and expose negative impressions. all that will build the project and build us, me, you :)
1305:53 PM → brendajerop1 joined (~Thunderbi@197.232.61.224)
1315:53 PM
132<r054l13> Rosalie give comments ask questions,
1335:54 PM in each of those, there will be something new to learn
1345:55 PM ⇐ brendajerop quit • brendajerop1 → brendajerop
1355:56 PM
136<r054l13> Rosalie I sent a mail on the mailing list about the wikimedia Code of Conduct committee needing new volunteers but I dont know how many applied to be part of the committee. I know just one person. but those are opportunities that expose to new experiences and possibilities to learn
1375:57 PM now to improve coding skills specifically
1385:59 PM It is more of practice makes perfect. keep coding to be a better coder. Don't know how I can say this better. This is what I was told and it is what I am sharing. The principle works :)
1395:59 PM In other words always have a task at hand and you will always have questions to ask in the community and you will always have new ideas and you will learn more ofcourse
1406:00 PM
141<wikibugs> Wikibugs v2.1, https://tools.wmflabs.org/wikibugs/ Pywikibot, Pywikibot-tests, Upstream: browseragents can not be installed - https://phabricator.wikimedia.org/T222959 (Xqt) >>! In T222959#5172755, @Dvorapa wrote: > No Then let remove that part
142<r054l13> Rosalie In a community the best way to learn anything is being active. anyone can correct me if I am making a mistake here:)
1436:03 PM That said we have touched all the agenda points.
1446:03 PM if there is no comment and nothing more...
1456:04 PM Thank you all for being part of this meeting
1466:05 PM
147<brendajerop> r054l13: Thank you for hosting
1486:05 PM
149<r054l13> Rosalie I hope we learnt something new today :)
1506:05 PM brendajerop: :D
1516:05 PM I will send relevant link on the mailing list
1526:07 PM brendajerop: could you send me the link to your project please
1536:08 PM want to make some documentation
1546:14 PM
155<jenniline> Jenniline Yes. Thanks I learned a lot. Thanks for the advice
1566:15 PM
157<wikibugs> Wikibugs v2.1, https://tools.wmflabs.org/wikibugs/ (PS2) Tombolano: Fix ordering by date and datetime fields in tables [extensions/Cargo] - https://gerrit.wikimedia.org/r/508959 (https://phabricator.wikimedia.org/T222843)
1586:15 PM
159<r054l13> Rosalie jenniline: cool
1606:16 PM
161<brendajerop> r054l13: https://phabricator.wikimedia.org/T215682
1626:16 PM
163<r054l13> Rosalie brendajerop: Thank you
1646:23 PM → m-alpha and math-alpha joined ⇐ brendajerop quit

Related Objects

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 5 2019, 2:53 AM
D3r1ck01 updated the task description. (Show Details)Apr 5 2019, 2:14 PM
rosalieper updated the task description. (Show Details)Apr 24 2019, 7:24 PM
rosalieper updated the task description. (Show Details)Apr 25 2019, 6:29 AM
rosalieper updated the task description. (Show Details)May 5 2019, 5:06 PM
rosalieper updated the task description. (Show Details)May 8 2019, 2:19 AM
rosalieper closed this task as Resolved.May 11 2019, 9:28 AM
D3r1ck01 updated the task description. (Show Details)May 11 2019, 9:52 AM
D3r1ck01 awarded a token.