Page MenuHomePhabricator

Calendar shows "Unhandled exception error: Expected a single result!"
Closed, ResolvedPublic

Description

When viewing Phabricator's calendar feature,
Phabricator states it expects a single Result and there is a unhandled exception (see below)

Reproduce:

  1. Log into Phab
  2. Visit https://phabricator.wikimedia.org/calendar/
  3. You'll see the error message

Event Timeline

RhinosF1 created this task.Apr 5 2019, 8:57 PM
RhinosF1 added a comment.EditedApr 5 2019, 8:59 PM

My Device info:
Device: iPhone 8 (MQ6H2B/A or A1905)
OS Version: iOS 12.2
Chrome Version:73.0.3683.68

RhinosF1 updated the task description. (Show Details)Apr 5 2019, 9:07 PM
JJMC89 added a subscriber: JJMC89.Apr 5 2019, 11:32 PM

I have replicated the exception while logged in and logged out using the below browsers on Windows 10.

  • Google Chrome Version 73.0.3683.86 (64-bit)
  • Firefox Quantum 66.0.2 (64-bit)
JJMC89 removed a subscriber: JJMC89.Apr 5 2019, 11:32 PM
mmodell claimed this task.Apr 5 2019, 11:51 PM

@mmodell, What's going on? Can you advise on workarounds?

What's going on?

A software bug.

Can you advise on workarounds?

Use https://phabricator.wikimedia.org/calendar/query/all/ or such.

Aklapper renamed this task from Unhandled exception error on Phabricator Calendar to Calendar shows "Unhandled exception error: Expected a single result!".Apr 6 2019, 10:03 AM

What's going on?

A software bug.

Very descriptive, Ive worked that out

Can you advise on workarounds?

Use https://phabricator.wikimedia.org/calendar/query/all/ or such.

Thank you

@RhinosF1: I don't know which problem "What's going on?" questions solve, apart from slowing down investigation. If the exact reason was already known and trivial to fix then there would likely also already a patch linked here. Anyway, off-topic for this very task... :)

@Aklapper, I was asking as when originally reporting on IRC I was advised to report here even though we were unsure whether this was Phabricator's issue or WikiMedia's installation of it.

I'd like to know so for future reference I can understand how's best to handle this and which it's more likely to be given @mmodell claimed the task without any comment.

You said if it was easy then I'd see a patch, if it's phab's issue then I wouldn't. It could have been silently reported and upstreamed by them.

Anyway, I won't rant.

@RhinosF1: https://www.mediawiki.org/wiki/How_to_report_a_bug applies as usual. Whether it's an upstream issue is irrelevant; someone will find out anyway.

To translate the conversation above to the real world: Something with your car does not work correctly. You bring it to a repair place as the task is to repair your car. A repair person claims the task by telling you they will investigate when they find time, without further comment. A few hours later you go there again and ask what's going on. Very likely they do not know yet and will tell you anyway once they have found time investigating and fix it.

@RhinosF1: https://www.mediawiki.org/wiki/How_to_report_a_bug applies as usual. Whether it's an upstream issue is irrelevant; someone will find out anyway.

Thanks for the Clarification, I'm assuming it's best to just report and let you lot figure it out.

To translate the conversation above to the real world: Something with your car does not work correctly. You bring it to a repair place as the task is to repair your car. A repair person claims the task by telling you they will investigate when they find time, without further comment. A few hours later you go there again and ask what's going on. Very likely they do not know yet and will tell you anyway once they have found time investigating and fix it.

You've not met me, I'd be looking for a garage that can do it as soon as possible and like to take control. I would be asking after a while if there's no timeline or idea of what's going on.

This is now fixed. Has anything changed recently?

RhinosF1 closed this task as Resolved.Apr 6 2019, 4:43 PM
Aklapper reopened this task as Open.Apr 6 2019, 4:55 PM

Heh. Then I can only ask you to please be more patient here. :)

It's not fixed for me. Reopening.

Heh. Then I can only ask you to please be more patient here. :)

I will take that advice seen as I don't really understand the technical side of the project yet.

It's not fixed for me. Reopening.

For me https://phabricator.wikimedia.org/calendar/ shows

mmodell triaged this task as Normal priority.Apr 8 2019, 5:04 PM

This is fixed in d7744d7e9bd0 but I haven't deployed it because I don't want to do a phab deploy from hotel wifi.

@mmodell @20after4: I note there's a phab deployment tommorow that you're doing. Will it be in that?

mmodell closed this task as Resolved.May 9 2019, 12:09 AM

@RhinosF1 it's been deployed now.