Page MenuHomePhabricator

session_token changes when opening new tabs
Closed, ResolvedPublic

Description

We noticed that the field session_token which we are using to isolate users, and based on which the schema sampling is done, resets when opening new tabs. This makes it more difficult to create the navigation history for users with multi-tab reading behavior.

Apparently, the problem is that the session_token is stored in window.sessionStorage and not window.localStorage/regular cookie:
https://github.com/wikimedia/mediawiki/blob/431aa3ea9aac0f924bd88df1a655f87d591d0e53/resources/src/mediawiki.user.js#L147

Is this something expected, or are we missing something?

Event Timeline

Restricted Application removed a project: Patch-For-Review. · View Herald TranscriptApr 8 2019, 3:13 PM

This was not expected. As pointed out in T118063#4547178 the documentation was misleading at the time.

Miriam closed this task as Resolved.Jul 4 2019, 5:47 PM

Resolved over email