Page MenuHomePhabricator

[Bug] Wrong number of notifications shown on initial edit
Closed, InvalidPublic

Description

Steps to reproduce

  1. Create a new account on the mobile MinervaNeue skin.
  2. Create an article.
  3. Visit an article.
  4. Open the notification panel.
  5. Close the notification panel.
  6. Open the notification panel.
  7. Tap "mark all as read".

Expected results

  • The correct number of notifications is shown.

Actual results

  • An alert that a new notification is available is shown but the number of notifications pending is zero. If you tap "mark all as read," a toast appears saying that "1 notification was marked as read".

Environments observed

  • Browser version: Chromium v73.0.3683.75
  • OS version: Ubuntu v18.10
  • Device model: Desktop
  • Device language: English

Event Timeline

Restricted Application added a project: Growth-Team. · View Herald TranscriptApr 9 2019, 2:30 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Niedzielski renamed this task from [Bug] Wrong number of notifications shown initially to [Bug] Wrong number of notifications shown on initial edit.Apr 9 2019, 2:30 PM
ovasileva triaged this task as Medium priority.Apr 9 2019, 3:07 PM
ovasileva moved this task from Incoming to Needs Prioritization on the Readers-Web-Backlog board.

Could not reproduce it in betalabs. Betalabs shows the correct behavior for a new user account:

  • a newly registered user cannot create an article in enwiki betalabs (this limitation matches the behavior in production)
  • the first notification is always welcome notification not the first edit notification.

Possibly affected by T220979.

Jdlrobson added a subscriber: Jdlrobson.

Hmm. I see a bell icon when I have zero notifications.
Can somebody in growth look at this? It seems we source this number from Echo APIs so I'm guessing we are either accessing incorrectly or there is a bug in Echo... let me know if web can help in any way.

Here's what I see locally on HEAD of Echo, MF, and Minerva:

  1. Create an article (1 notification count, it's the "Welcome" notification) and reload the page (notification count of 2, the second one is thanks for the first edit)

  1. Close the panel without interacting with the notifications:

  1. Tap mark all as read:

  1. Close the panel

  1. Reload the page


This all seems to be correct behavior, AFAICT. @Niedzielski are you still seeing this issue?

Niedzielski closed this task as Invalid.Apr 23 2019, 2:34 PM

Sorry, I can no longer reproduce this issue on master.