Page MenuHomePhabricator

"Move Tasks to Column..." opens dialogue for moving to project
Closed, ResolvedPublic

Description

Steps to reproduce:

  1. On a workboard, open a column menu (down triangle in the top right corner in a column)
  2. Select "Move Tasks to Column..."

Actual result:
Opens dialogue for moving tasks to another project.

Expected result:
Allows you to move tasks to another column.

Event Timeline

@Sebastian_Berlin-WMSE: AFAIU that's intended and a feature. The dialog for moving tasks preselects the existing project. After that you can choose the column. Is that not the case for you? If it is not, can you point to a specific project/workboard column where this problem happens?

It does indeed do what it's supposed to. I never tried continuing because the label says "Move to Project", which I read as "Select the project that you want to move these tasks to." I think the label should be rephrased to avoid confusion.

Aklapper triaged this task as Lowest priority.May 27 2019, 3:02 PM
Aklapper edited projects, added Phabricator (Upstream); removed Phabricator.

Hmm. Well, you "move" the tasks to the very same project... I'm not sure how upstream shall rephrase it?

Restricted Application added a project: Upstream. · View Herald TranscriptMay 27 2019, 3:02 PM
epriestley added a subscriber: epriestley.

I think we can do something to make this less confusing, this isn't the first time I've seen someone run into trouble with it.

One fix would be to give you a modal choice instead:

+-------------------------------------------------+
|                                                 |
|  ( Move to another column on this workboard )   |
|                                                 |
|  ( Move to a different workboard            )   |
|                                                 |
+-------------------------------------------------+
|                                      [ Cancel ] |
+-------------------------------------------------+

Another fix, which I'm sort of leaning toward, would be to split this action into two menu items, "Move to Column..." (which skips the first step of the dialog) and "Move to Another Workboard...".

Both these fixes are sort of silly because they add more steps, options, and/or complexity to the workflow, but I think they're likely to ultimately make it more clear. I think about 95% of the time you want to move to a column on the same workboard when you pick this option, and it's reasonable that users are already in a mindset where they want to select a column when the dialog appears and asks them to select a project instead.

I think about 95% of the time you want to move to a column on the same workboard when you pick this option [...]

That's what I thought this option did. In fact, I haven't tried using this for other projects than the current one and am not sure what it would actually do; move all tasks to selected project and column, move all tasks already in that project to selected column or something else.

Anyhow, I think it may be less confusing if you have both selections in the same dialogue. This way, people like me wouldn't think they somehow ended up in the wrong place.

I think this will be substantially improved by the upstream change in https://secure.phabricator.com/D20636, which separates these actions:

(This is still in review upstream and may take some time to make it to a release and then deploy here.)

Aklapper closed this task as Resolved.Aug 23 2019, 8:00 AM