Page MenuHomePhabricator

Can't submit file captions on Wikimedia Commons using Microsoft Edge on a mobile device
Closed, ResolvedPublic

Description

I generally use two (2) devices to upload images to Wikimedia Commons, I use a Microsoft Lumia 950 XL phablet for uploading images from other websites to Wikimedia Commons on which I mostly use the Microsoft Edge web browser. And I use an Elephone P8 Mini mobile telephone 📞 for my own photography (as the camera on my ML950XL is broken) with the Ecosia web browser, when I use the latter I insert text in the field "Caption" while using the MediaWiki Upload Wizard and after publishing the file captions appear to the attached files.

Meanwhile when I upload an image using my ML950XL with Microsoft Edge, where I also use the mobile version of the MediaWiki Upload Wizard, the page says "submitting captions..." during the upload phase, but after I open the file page no captions seem to be present nor am I performing the edits (despite the MediaWiki Upload Wizard telling me otherwise) and the files get published without any errors.

I've run into this issue since about April 8th and it only seems to affect Microsoft Edge, I have not tried it using Microsoft Edge on another operating system or form factor so this might be an issue with the browser or not.

Related Objects

Event Timeline

DonTrung created this task.Apr 10 2019, 8:06 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 10 2019, 8:06 PM

Just to be clear, I select a file, I upload it, I give it an appropriate file name, I write a file caption, I fill in the file description, add it to the appropriate categor(y/ies), and then publish it. I do this on both devices, but while the file captions so show up on my Elephone P8 Mini (Android operating system, Ecosia web browser) they don't on my Microsoft Lumia 950 XL (Microsoft Windows 10 Mobile, Microsoft Edge web browser).

Also to clarify the title, I CAN "submit" them, and the MediaWiki Upload Wizard tells me that they are published, however the actual edits adding the file captions to the "Structured Data" field are never actually performed.

+ another clarification, I can still add file captions manually on the file pages individually, but not through the MediaWiki Upload Wizard.

@Aklapper, oddly enough the issue seems to have been resolved, has an update to the website been issued last night? I didn't change anything on my phablet.

matthiasmullie closed this task as Resolved.Apr 11 2019, 1:05 PM
matthiasmullie claimed this task.
matthiasmullie added a subscriber: matthiasmullie.

Yes, a couple of changes to UploadWizard were deployed yesterday.
I'm not sure exactly what your problem was, or what fixed it, though - I suspect https://gerrit.wikimedia.org/r/c/mediawiki/extensions/UploadWizard/+/501188 has fixed your issue, but I'm confused at why it was different in different browsers.
Anyway, glad to hear it's been resolved now!
I'll close this ticket - should you continue to encounter this issue, feel free to reopen!