Page MenuHomePhabricator

Can't save preferences using microsoft edge (buttons with "position: sticky" disappear in RTL languages when using Edge)
Closed, ResolvedPublic

Description

(disclosure: i do not have access to micro$oft edge - this report is made for several users on hewiki)

REPRODUCTION:

  1. obtain microsoft edge
  2. login to your wikimedia account
  3. open hewiki
  4. go to preferences

EXPECTED:

  1. expect to see grayed out button at bottom of page with "save" (or rather , "שמירה")
  2. expect this button to become blue when making any change to the preference page

OBSERVED

  1. no visible grayed "שמירה" button
  2. it does not become visible when changing a preference
NOTE: i do not know if this is specific to hewiki. with high probability, this can be observed on any other wiki (as long as you manage to put your hands on an EDGE browser), but as mentioned, i do not have access to such browser, and the reports were about hewiki.

peace

Event Timeline

Kipod created this task.Apr 11 2019, 3:01 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 11 2019, 3:01 PM
Kipod added a comment.Apr 12 2019, 1:59 AM

additional information:
user reports that on enwiki, and on hewiki with "uselang=en", she _does_ sees the "Save" button, but not with hebrew ui.

peace.

Could you please try this with safemode=1? This allows you to test if a problem is because of your user scripts or personal gadgets without uninstalling them. See https://www.mediawiki.org/wiki/Help:Locating_broken_scripts for more information.

Kipod added a comment.EditedApr 12 2019, 3:24 PM

Could you please try this with safemode=1? This allows you to test if a problem is because of your user scripts or personal gadgets without uninstalling them. See https://www.mediawiki.org/wiki/Help:Locating_broken_scripts for more information.

i can ask the users, but i believe this is not useful: remember, when opening a page in Special:Preferences, media wiki does not load personal scripts and gadgets anyway.

if anything, i'd suggest adding "debug=1", to get more comprehensive console.log messages,

for now, i only asked the users reporting the problem to look in JS console and copy all the messages, and if they'll provide this information, i will copy it here (unless, of course, some development on the ticket will render this useless -e.g., someone may solve the problem)

peace

YonaB added a subscriber: YonaB.EditedApr 13 2019, 6:38 PM

additional information:
It happen in all wikipedias when the preferce language is hebrew (I checked it in en-wiki and ro-wiki).
In ro-wiki, I don't have any user script or gadget and it still happen. I still check with safemode=1 but it didn't change it.

I checked in consol and the only warning appear when the language is hebrew and not in other languages (I checked french and English too) is:

This page is using the deprecated ResourceLoader module "mediawiki.ui".
Please use OOUI instead.

another user have copied the whole content of her console:

  JQMIGRATE: Migrate is installed with logging active, version 3.0.1

 This page is using the deprecated ResourceLoader module "jquery.throttle-debounce".
Please use OO.ui.throttle/debounce instead. See https://phabricator.wikimedia.org/T213426

 This page is using the deprecated ResourceLoader module "jquery.ui.position".

 This page is using the deprecated ResourceLoader module "jquery.ui.widget".

 This page is using the deprecated ResourceLoader module "jquery.tipsy".

 This page is using the deprecated ResourceLoader module "jquery.ui.core".
Please use OOUI instead.

 SEC7115: :visited and :link styles can only differ by color. Some styles were not applied to :visited.
%D7%9E%D7%A9%D7%AA%D7%9E%D7%A9%D7%AA:BlueHorizon (1,1)

 HTML1300: התבצע ניווט.
%D7%9E%D7%99%D7%95%D7%97%D7%93:%D7%A8%D7%A9%D7%99%D7%9E%D7%AA_%D7%94%D7%9E%D7%A2%D7%A7%D7%91 (1,1)

 SEC7115: :visited and :link styles can only differ by color. Some styles were not applied to :visited.
%D7%9E%D7%99%D7%95%D7%97%D7%93:%D7%A8%D7%A9%D7%99%D7%9E%D7%AA_%D7%94%D7%9E%D7%A2%D7%A7%D7%91 (1,1)

 JQMIGRATE: Migrate is installed with logging active, version 3.0.1

 This page is using the deprecated ResourceLoader module "jquery.throttle-debounce".
Please use OO.ui.throttle/debounce instead. See https://phabricator.wikimedia.org/T213426

 This page is using the deprecated ResourceLoader module "jquery.ui.position".

 This page is using the deprecated ResourceLoader module "jquery.ui.widget".

 This page is using the deprecated ResourceLoader module "jquery.tipsy".

 This page is using the deprecated ResourceLoader module "jquery.ui.core".
Please use OOUI instead.

 HTTP404: ‏‏NOT FOUND (לא נמצא) - השרת לא מצא שום דבר שתואם ל- URI (מזהה משאבים אחיד) המבוקש.
(XHR)GET - https://he.wikipedia.org/w/index.php?title=%D7%9E%D7%A9%D7%AA%D7%9E%D7%A9%3ABlueHorizon%2F%D7%94%D7%A7%D7%99%D7%A9%D7%95%D7%A8%D7%99%D7%9D%20%D7%A9%D7%9C%D7%99&action=render

 HTML1300: התבצע ניווט.
%D7%9E%D7%99%D7%95%D7%97%D7%93:%D7%94%D7%A2%D7%93%D7%A4%D7%95%D7%AA (1,1)

 JQMIGRATE: Migrate is installed with logging active, version 3.0.1

 This page is using the deprecated ResourceLoader module "jquery.throttle-debounce".
Please use OO.ui.throttle/debounce instead. See https://phabricator.wikimedia.org/T213426

 SEC7115: :visited and :link styles can only differ by color. Some styles were not applied to :visited.

peace.

The issue is also reproducible at https://en.wikipedia.org/wiki/Special:Preferences?uselang=he, so it shouldn't be anything site-specific.

The button appears when I remove position: sticky from it in the developer tools. I suspect this is a browser bug.

Upstream bug: https://developer.microsoft.com/en-us/microsoft-edge/platform/issues/18883305/

I can confirm that the workaround described there works:

Michael M.

I found a workaround: set a CSS filter that does nothing to the element containing the “position: sticky” element e.g.:
filter: brightness(1);
The tab crashes when you inspect the “position: sticky” element, but at least for non-developers it seems to work -_-

It doesn't cause any crashes for me though!

Change 511965 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/core@master] Work around disappearing Special:Preferences buttons on RTL in Edge

https://gerrit.wikimedia.org/r/511965

Maybe also related upstream bug: https://developer.microsoft.com/en-us/microsoft-edge/platform/issues/15754013/

For reference, I am using:

Microsoft Edge 42.17134.1.0
Microsoft EdgeHTML 17.17134

matmarex renamed this task from Can't save preferences using microsoft edge to Can't save preferences using microsoft edge (buttons with "position: sticky" disappear in RTL languages when using Edge).May 22 2019, 7:43 PM
matmarex added a subscriber: Esanders.

Change 511965 merged by jenkins-bot:
[mediawiki/core@master] Work around disappearing Special:Preferences buttons on RTL in Edge

https://gerrit.wikimedia.org/r/511965

matmarex closed this task as Resolved.May 23 2019, 3:20 PM
matmarex claimed this task.