Page MenuHomePhabricator

Hostname settings on phab1001.eqiad.wmnet
Closed, ResolvedPublic

Description

What can be found in /etc/hostname on phab1001.eqiad.wmnet [2620:0:861:102:10:64:16:8]? Ī̲ can bet that its content is currently “localhost”. And what is the argument to domain in /etc/resolv.conf? Unlikely there is such line at all.

Putting the machine’s individual name and the domain name into relevant settings is one of first tasks for a system administrator who creates an Internet server. When one sees “Message-ID: <⋯@localhost.localdomain>”, an immediate conclusion is that the message originates from a box where a lazy admin works.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 11 2019, 3:33 PM
Aklapper changed the task status from Open to Stalled.Apr 11 2019, 3:48 PM
Aklapper removed a subscriber: Phabricator_maintenance.

Hi @Incnis_Mrsi. This task does not explain why these questions are asked. If there is some issue with something, read and follow https://www.mediawiki.org/wiki/How_to_report_a_bug and provide: 1) a clear list of specific steps to reproduce the situation, 2) describing actual results, 3) describing expected results.
You can edit the task description by clicking Edit Task. Thanks.

Aklapper changed the task status from Stalled to Open.Apr 11 2019, 4:41 PM
Aklapper added a project: Mail.

@Incnis_Mrsi: If this is about Phabricator mail notification headers like

Received: from localhost ([::1]:47496 helo=localhost.localdomain)
        by phab1001.eqiad.wmnet with esmtp (Exim 4.84_2)
        (envelope-from <no-reply@phabricator.wikimedia.org>)
        id 1hEbpk-0001t7-9S; Thu, 11 Apr 2019 15:41:48 +0000
Message-ID: <2ce697433b618f546afd500e96362c1b@localhost.localdomain>

and replacing the localhost.localdomain in there, then you could just write that this is about Phabricator mail notification headers.
No need to get personal about potentially "lazy system administrators". Please see https://www.mediawiki.org/wiki/Bug_management/Phabricator_etiquette

What can be found in /etc/hostname on phab1001.eqiad.wmnet [2620:0:861:102:10:64:16:8]? Ī̲ can bet that its content is currently “localhost”.

No, that isn't accurate. The content of /etc/hostname is: phab1001

And what is the argument to domain in /etc/resolv.conf? Unlikely there is such line at all.

[phab1001:~] $ cat /etc/resolv.conf 
#####################################################################
#### THIS FILE IS MANAGED BY PUPPET
####  as template('base/resolv.conf.erb')
#####################################################################
# Resolver configuration for site eqiad
search eqiad.wmnet codfw.wmnet
options timeout:1 attempts:3
nameserver 208.80.154.254
nameserver 208.80.153.254

Both hostname -s and hostname -f show accurate results.

[phab1001:~] $ hostname -s
phab1001
[phab1001:~] $ hostname -f
phab1001.eqiad.wmnet

Putting the machine’s individual name and the domain name into relevant settings is one of first tasks for a system administrator who creates an Internet server.

That's not how this works here. Nobody is manually editing those files. That doesn't scale. We are using puppet. The resolv.conf.erb is in the public repository operations/puppet. Feel free to suggest patches but first please define the actual problem you are trying to solve.

herron closed this task as Resolved.Apr 11 2019, 4:52 PM
herron claimed this task.
herron added a subscriber: herron.

Localhost is seen in the mail headers because the Phabricator application relays mail to a local Exim MTA via SMTP. The local MTA provides message queueing and outbound SMTP server failover. This was done intentionally to improve the reliability of email delivery from Phabricator.

… because the Phabricator application relays mail having no Message-ID header of its own to a local Exim MTA. Unlikely Exim would replace an existing ID with crap. IMHO not a good practice, to send Emails lacking Message-ID.