Page MenuHomePhabricator

1.34.0-wmf.1 deployment blockers
Closed, ResolvedPublicRelease

Details

2019 week 16 1.34-wmf.1 Changes wmf/1.34.0-wmf.1

This MediaWiki Train Deployment is scheduled for the week of Monday, April 15th:

Monday April 15thTuesday, April 16thWednesday, April 17thThursday, April 18thFriday
SWAT deployments only.Branch wmf.1 and deploy to Group 0 Wikis.Deploy wmf.1 to Group 1 Wikis.Deploy wmf.1 to all Wikis.No deployments on fridays

How this works

  • Any serious bugs affecting wmf.1 should be added as subtasks beneath this one.
  • Any open subtask(s) block the train from moving forward.This means no further deployments until the blockers are resolved.
  • If something is serious enough to warrant a rollback then you should bring it to the attention of deployers on the #wikimedia-operations IRC channel.
  • For more info about deployment blockers, see Holding the train.

Related Links

Other Deployments

Previous: 1.33.0-wmf.26
Next: 1.34.0-wmf.2

Event Timeline

mmodell created this task.Apr 11 2019, 6:14 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 11 2019, 6:14 PM
mmodell claimed this task.Apr 11 2019, 6:45 PM
mmodell triaged this task as Normal priority.Apr 11 2019, 7:08 PM

Mentioned in SAL (#wikimedia-operations) [2019-04-16T18:46:00Z] <twentyafterfour> branching 1.34.0-wmf.1 refs T220726

Change 504428 had a related patch set uploaded (by 20after4; owner: 20after4):
[operations/mediawiki-config@master] testwikis wikis to 1.34.0-wmf.1 refs T220726

https://gerrit.wikimedia.org/r/504428

Change 504428 merged by jenkins-bot:
[operations/mediawiki-config@master] testwikis wikis to 1.34.0-wmf.1 refs T220726

https://gerrit.wikimedia.org/r/504428

Mentioned in SAL (#wikimedia-operations) [2019-04-16T20:45:01Z] <twentyafterfour@deploy1001> Started scap: testwikis wikis to 1.34.0-wmf.1 refs T220726

Mentioned in SAL (#wikimedia-operations) [2019-04-16T21:21:49Z] <twentyafterfour@deploy1001> Finished scap: testwikis wikis to 1.34.0-wmf.1 refs T220726 (duration: 36m 47s)

Change 504439 had a related patch set uploaded (by 20after4; owner: 20after4):
[operations/mediawiki-config@master] group0 wikis to 1.34.0-wmf.1 refs T220726

https://gerrit.wikimedia.org/r/504439

Change 504439 merged by jenkins-bot:
[operations/mediawiki-config@master] group0 wikis to 1.34.0-wmf.1 refs T220726

https://gerrit.wikimedia.org/r/504439

Mentioned in SAL (#wikimedia-operations) [2019-04-16T21:47:34Z] <twentyafterfour@deploy1001> rebuilt and synchronized wikiversions files: group0 wikis to 1.34.0-wmf.1 refs T220726

Change 504655 had a related patch set uploaded (by 20after4; owner: 20after4):
[operations/mediawiki-config@master] group1 wikis to 1.34.0-wmf.1 refs T220726

https://gerrit.wikimedia.org/r/504655

Change 504655 merged by jenkins-bot:
[operations/mediawiki-config@master] group1 wikis to 1.34.0-wmf.1 refs T220726

https://gerrit.wikimedia.org/r/504655

Mentioned in SAL (#wikimedia-operations) [2019-04-17T19:13:03Z] <twentyafterfour@deploy1001> rebuilt and synchronized wikiversions files: group1 wikis to 1.34.0-wmf.1 refs T220726

Mentioned in SAL (#wikimedia-operations) [2019-04-17T19:14:53Z] <twentyafterfour@deploy1001> Synchronized php: group1 wikis to 1.34.0-wmf.1 refs T220726 (duration: 01m 49s)

greg added a subscriber: greg.Apr 18 2019, 7:07 PM

Mentioned in SAL (#wikimedia-operations) [2019-04-17T19:14:53Z] <twentyafterfour@deploy1001> Synchronized php: group1 wikis to 1.34.0-wmf.1 refs T220726 (duration: 01m 49s)

Did that actually happen? I see 1.33 wmf.25 on https://commons.wikimedia.org/wiki/Special:Version and corroborating info at https://tools.wmflabs.org/versions/

greg added subscribers: Joe, Reedy.Apr 18 2019, 7:08 PM

I see now:

@Reedy graciously reverted group 1 for me, as this was the cause for a UBN! ticket.

Change 504983 had a related patch set uploaded (by 20after4; owner: 20after4):
[operations/mediawiki-config@master] all wikis to 1.34.0-wmf.1 refs T220726

https://gerrit.wikimedia.org/r/504983

Change 504983 merged by jenkins-bot:
[operations/mediawiki-config@master] all wikis to 1.34.0-wmf.1 refs T220726

https://gerrit.wikimedia.org/r/504983

Mentioned in SAL (#wikimedia-operations) [2019-04-18T20:56:24Z] <twentyafterfour@deploy1001> rebuilt and synchronized wikiversions files: all wikis to 1.34.0-wmf.1 refs T220726

mmodell closed this task as Resolved.Apr 19 2019, 5:55 PM