Page MenuHomePhabricator

1.34.0-wmf.7 deployment blockers
Closed, ResolvedPublicRelease

Details

Release Version
1.34.0-wmf.7
Release Date
1558915200

2019 week 22 1.34-wmf.7 Changes wmf/1.34.0-wmf.7

This MediaWiki Train Deployment is scheduled for the week of Monday, May 27th:

Monday May 27thTuesday, May 28thWednesday, May 29thThursday, May 30thFriday
SWAT deployments only.Branch wmf.7 and deploy to Group 0 Wikis.Deploy wmf.7 to Group 1 Wikis.Deploy wmf.7 to all Wikis.No deployments on fridays

How this works

  • Any serious bugs affecting wmf.7 should be added as subtasks beneath this one.
  • Any open subtask(s) block the train from moving forward.This means no further deployments until the blockers are resolved.
  • If something is serious enough to warrant a rollback then you should bring it to the attention of deployers on the #wikimedia-operations IRC channel.
  • For more info about deployment blockers, see Holding the train.

Related Links

Other Deployments

Previous: 1.34.0-wmf.6
Next: 1.34.0-wmf.8

Event Timeline

mmodell created this task.Apr 11 2019, 6:15 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 11 2019, 6:15 PM
zeljkofilipin removed zeljkofilipin as the assignee of this task.Apr 11 2019, 7:03 PM
zeljkofilipin added a subscriber: zeljkofilipin.

Unassigning from myself, since this is in a couple of months. I'll assign it back to me in time.

mmodell triaged this task as Medium priority.Apr 11 2019, 7:11 PM

Group0 at 1.34.0-wmf.7 (gerrit, wikitech, sal).

Tgr added a subscriber: Tgr.May 28 2019, 4:17 PM

T224493: Call to undefined method CommentStore::getCommentInternal happened in the middle of the train period, any thoughts?

@Tgr T224493 was closed as duplicate of T224491, and it's not added to train blockers.

Group1 at 1.34.0-wmf.7 (gerrit, wikitech, sal).

Group2 at 1.34.0-wmf.7 (gerrit, wikitech, sal).

zeljkofilipin closed this task as Resolved.May 31 2019, 9:53 AM