Page MenuHomePhabricator

'Items depicts in this File' text sometimes in German
Closed, ResolvedPublic

Description

https://test-commons.wikimedia.org/wiki/File:Kreuzgraben.jpg?uselang=en

Click on 'Structured data' tab - see the text 'In dieser Datei abgebildete Objekte' instead of 'Items portrayed in this file'

Purging caches seems to have no effect

https://test-commons.wikimedia.org/wiki/File:Kreuzgraben.jpg?uselang=fr has the text in French

Event Timeline

Cparle created this task.Apr 15 2019, 4:48 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 15 2019, 4:48 PM

File had been uploaded and edited by one user, who presumably has de as their user interface language. As every logged-in-user render of the page would have been into that user's language, it'd have been in German, but it's odd that that bit of the interface didn't uncache correctly when the rest did.

Fixed by doing an action=purge on the file with an English locale. Might just be an old page cache issue from the roll out of testing code, or might be more systemic.

Hmm. I'm gonna test this one a bit more in multiple languages. Tagging the rest of the team for additional eyes on it/insight

Ramsey-WMF triaged this task as Medium priority.Apr 16 2019, 5:24 PM

After a few tests, have been unable to reproduce this on Test commons (with a new upload, with an old upload that didn't have depicts yet, etc.). Will move to VoP for now, but I'm still a little wary about this one.

Ramsey-WMF moved this task from Untriaged to Next up on the Multimedia board.
Ramsey-WMF closed this task as Resolved.Apr 23 2019, 9:00 PM

Can't reproduce on production, even on files with depicts values added in non-English the first time, so I'm closing this.