Page MenuHomePhabricator

Cannot edit statements for certain images
Closed, ResolvedPublicBUG REPORT

Description

User story: N/A

We have this:
No edit button on Statements Panel for files such as:
https://commons.wikimedia.beta.wmflabs.org/wiki/File:T220613.png

We want this:
You can edit statements and edit button appears

Screenshots (if possible):

Acceptance Criteria:

  • edit button is present on statements panel

Event Timeline

Ha78na created this task.Apr 16 2019, 5:01 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 16 2019, 5:01 PM
Ramsey-WMF triaged this task as High priority.Apr 16 2019, 5:26 PM
Ramsey-WMF moved this task from Untriaged to Next up on the Multimedia board.

Change 504366 had a related patch set uploaded (by Matthias Mullie; owner: Matthias Mullie):
[mediawiki/extensions/WikibaseMediaInfo@master] Don't use value until having checked there is one

https://gerrit.wikimedia.org/r/504366

Seem blocked by failures due to T221111

Change 504366 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@master] Don't use value until having checked there is one

https://gerrit.wikimedia.org/r/504366

Ha78na claimed this task.Apr 16 2019, 9:40 PM
Ha78na added a subscriber: matthiasmullie.

This is working properly now on Beta again.

Change 504575 had a related patch set uploaded (by Jforrester; owner: Matthias Mullie):
[mediawiki/extensions/WikibaseMediaInfo@wmf/1.34.0-wmf.1] Don't use value until having checked there is one

https://gerrit.wikimedia.org/r/504575

Change 504575 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@wmf/1.34.0-wmf.1] Don't use value until having checked there is one

https://gerrit.wikimedia.org/r/504575

Mentioned in SAL (#wikimedia-operations) [2019-04-17T16:47:40Z] <jforrester@deploy1001> Synchronized php-1.34.0-wmf.1/extensions/WikibaseMediaInfo/: SDC: Various fixes T218922 T221071 T221110 T221123 (duration: 01m 02s)

Cparle added a subscriber: Cparle.Apr 18 2019, 11:42 AM

Ok on test-commons

Ramsey-WMF closed this task as Resolved.Apr 23 2019, 8:50 PM

Confirmed to be working on Production, logged in and logged out, on 4/23