Page MenuHomePhabricator

Adding multiple captions at once is v broken (Beta Commons)
Closed, ResolvedPublicBUG REPORT

Description

https://commons.wikimedia.beta.wmflabs.org/wiki/Special:Random/file - look for a file that has no captions currently, it will make life easier for testing purposes

  1. Scroll to the captions section, click "edit"
  2. Click "Add a caption" a number of times. I saw this bug with as few as five, but more will probably increase the wonkiness.
  3. Enter a language and text for each caption
  4. Click "publish changes"

Expected behavior: All captions are saved and the page is put into read-mode

Actual behavior: Some of the captions (three or four) are saved, some of the remaining captions are put into edit-mode, others are disabled (as if they were still being worked on). The "publish changes" button is re-enabled, but editing any of the enabled caption fields re-disables it. Deleting rows seems to work (for the enabled captions). Disabled captions' languages can still be changed in the interface, but it's unclear to me now if that causes them to actually be saved with the new language value.

Will test now on production to see if this happens there.

Details

Related Gerrit Patches:
mediawiki/extensions/WikibaseMediaInfo : wmf/1.34.0-wmf.1Don't remove textInput after having submitted it
mediawiki/extensions/WikibaseMediaInfo : masterDon't remove textInput after having submitted it

Event Timeline

Restricted Application added a project: Multimedia. · View Herald TranscriptApr 16 2019, 5:43 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

In production: I submitted nine captions for https://commons.wikimedia.org/wiki/File:Sollentuna_kyrka_-_KMB_-_16000200131314.jpg - five went through initially, then re-submitting the form saved a sixth, but the other three were uneditable and the publish button was once again disabled.

Ramsey-WMF triaged this task as Medium priority.Apr 16 2019, 5:52 PM
Ramsey-WMF changed the subtype of this task from "Task" to "Bug Report".
Ramsey-WMF moved this task from Untriaged to Next up on the Multimedia board.
egardner added a subscriber: egardner.EditedApr 16 2019, 5:56 PM

In my case the panel ended up in a frozen disabled state, where some captions had been submitted and others not – no error message or failed requests, just UI freeze:

But on a forced reload, it looks like the other requests went through?

@egardner I'm fascinated by that screenshot, not only because it's inconsistently broken (the best kind of broken, obviously), but also because it looks like you have an empty caption that it allowed you to submit. Perhaps more is broken here than we realize!

Even the brokenness is broken...

egardner claimed this task.Apr 16 2019, 6:27 PM

Change 504410 had a related patch set uploaded (by Matthias Mullie; owner: Matthias Mullie):
[mediawiki/extensions/WikibaseMediaInfo@master] Don't remove textInput after having submitted it

https://gerrit.wikimedia.org/r/504410

egardner removed egardner as the assignee of this task.Apr 16 2019, 6:54 PM

Change 504410 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@master] Don't remove textInput after having submitted it

https://gerrit.wikimedia.org/r/504410

Ha78na moved this task from Code Review to Needs QA on the Structured-Data-Team-Current-Work board.
Ha78na added a subscriber: matthiasmullie.

Change 504574 had a related patch set uploaded (by Jforrester; owner: Matthias Mullie):
[mediawiki/extensions/WikibaseMediaInfo@wmf/1.34.0-wmf.1] Don't remove textInput after having submitted it

https://gerrit.wikimedia.org/r/504574

Change 504574 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@wmf/1.34.0-wmf.1] Don't remove textInput after having submitted it

https://gerrit.wikimedia.org/r/504574

Cparle added a subscriber: Cparle.Apr 18 2019, 9:45 AM

Works fine now on beta, and on test-commons until you hit the rate limit for api calls

Ramsey-WMF closed this task as Resolved.Apr 24 2019, 1:05 AM
Ramsey-WMF added a subscriber: Ramsey-WMF.

Looks clean on production (tested logged in with 9 new captions)