Page MenuHomePhabricator

Display popover to users when encountering unsupported statements on FP
Closed, ResolvedPublic

Description

User story: As a Commons editor, if I run into an unsupported statement, I want more information about it, so that I can understand why it's greyed out.

We have this:

We want this:

Acceptance Criteria:

  • Popover displays to user with instructional text

See this ticket for background info: T219381

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 18 2019, 12:52 PM
PDrouin-WMF renamed this task from [stub] Tooltip for unsupported statements on FP to Display popover to users when encountering unsupported statements on FP.Apr 18 2019, 2:59 PM
PDrouin-WMF removed PDrouin-WMF as the assignee of this task.
PDrouin-WMF updated the task description. (Show Details)
PDrouin-WMF added a subscriber: Ramsey-WMF.
Restricted Application added a project: Multimedia. · View Herald TranscriptApr 18 2019, 2:59 PM
Ramsey-WMF moved this task from Untriaged to Triaged on the Multimedia board.Apr 25 2019, 8:22 PM
Ramsey-WMF triaged this task as Normal priority.
Ramsey-WMF added a subscriber: matthiasmullie.

Feedback on this one, @matthiasmullie ?

Looks good to me, except the last sentence: "For the time being, it is uneditable".
They are already editable, and I suggest we don't take that away (because that'd also mean taking away the possibility to remove such vandalism)
Ok if we just drop that last sentence?

So, since we actually do support editing:

When user clicks "edit":

  • the widget goes into edit mode
  • it displays the popup (which now appears under the grayed out "published changes" button, because we're in edit mode)
  • clicking anywhere outside of the popup dismisses it

(see clip below to see it in action)

Does this work?

Change 506600 had a related patch set uploaded (by Matthias Mullie; owner: Matthias Mullie):
[mediawiki/extensions/WikibaseMediaInfo@master] Display popover to users when encountering unsupported statements on FP

https://gerrit.wikimedia.org/r/506600

matthiasmullie moved this task from To Do to Code Review on the Multimedia-Current-Work board.

Thanks, @matthiasmullie

Functionally, I think this works fine. I think we need just a couple more tweaks

  • Where is that "Learn more" link supposed to go? 😸
  • Adjusting the text in the popover a bit so it's more detailed. Maybe something like "Properties other than depicts are not yet fully supported, but will be in the future. For now, functionality for unsupported properties may not work as you might expect."

I updated the copy.

Not sure where "learn more" is supposed to go :) (right now, it goes to the same place as the depicts "Learn more" link: https://commons.wikimedia.org/wiki/Commons:Depicts)
Alternative suggestions? Or drop it?

Since it's temporary (hopefully very temporary!) it'd be okay to drop it.

Okay - updated patch, dropped link!

Change 506600 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@master] Display popover to users when encountering unsupported statements on FP

https://gerrit.wikimedia.org/r/506600

Ramsey-WMF closed this task as Resolved.Tue, Jun 11, 5:59 PM

Tested and confirmed on production with https://commons.wikimedia.org/wiki/File:Franz_Joachim_Beich_-_Die_Eroberung_der_Festung_Ofen_1686_-_2582_-_Bavarian_State_Painting_Collections.jpg (which used a digital representation of property which is not currently supported)