Page MenuHomePhabricator

Implement PropertyTermStore wikibase-term-store using MW DBAL
Closed, InvalidPublic

Description

This is implemented in a separate repo https://github.com/wmde/mediawiki-term-store which is an wikibase-term-store implementaion using MW DBAL.

GH PR: https://github.com/wmde/mediawiki-term-store/pull/11

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 23 2019, 8:48 PM
alaa_wmde renamed this task from [Story] Implemen wikibase-term-store using MW DBAL to [Story] Implement wikibase-term-store using MW DBAL.Apr 23 2019, 9:06 PM
alaa_wmde renamed this task from [Story] Implement wikibase-term-store using MW DBAL to Implement PropertyTermStore wikibase-term-store using MW DBAL.

The MW DBAL implementation will reside inside Wikibase extension code-base for now.
That is because:

  • MW DBAL is not extracted outside of mediawiki/core as a separate package
  • mediawiki/core is not provided as a package one can depend on (at least dev dependencies for tests)

if one of the above two wasn't true, it would've been easier to do a separate library for MW DBAL implementation of wikibase-term-store.

Change 506692 had a related patch set uploaded (by Alaa Sarhan; owner: Alaa Sarhan):
[mediawiki/extensions/Wikibase@master] [WIP] Adding MediaWikieTermStore, first with only PropertyTermStore implementation.

https://gerrit.wikimedia.org/r/506692

Change 507275 had a related patch set uploaded (by Alaa Sarhan; owner: Alaa Sarhan):
[mediawiki/extensions/Wikibase@master] Add SchemaAccess interface to abstract normalized terms schema access from mediawiki dbal's implementation of wikibase-term-store

https://gerrit.wikimedia.org/r/507275

Change 507276 had a related patch set uploaded (by Alaa Sarhan; owner: Alaa Sarhan):
[mediawiki/extensions/Wikibase@master] Add InMemorySchemaAccess test helper class

https://gerrit.wikimedia.org/r/507276

Change 507277 had a related patch set uploaded (by Alaa Sarhan; owner: Alaa Sarhan):
[mediawiki/extensions/Wikibase@master] Add MediaWikiDatabaseAccess implementation of SchemaAccess.

https://gerrit.wikimedia.org/r/507277

Change 506692 abandoned by Alaa Sarhan:
[WIP] Adding MediaWikieTermStore, first with only PropertyTermStore implementation.

Reason:
Abandoned in favor of smaller series of patches (follow from the connected Bug https://phabricator.wikimedia.org/T221706)

https://gerrit.wikimedia.org/r/506692

Change 507824 had a related patch set uploaded (by Alaa Sarhan; owner: Alaa Sarhan):
[mediawiki/extensions/Wikibase@master] Add MediaWikiDatabaseEntityTermStore implementation of EntityTermStoreSchemaAccess.

https://gerrit.wikimedia.org/r/507824

Change 507824 abandoned by Alaa Sarhan:
Add MediaWikiDatabaseEntityTermStore implementation of EntityTermStoreSchemaAccess.

Reason:
Follow on https://github.com/wmde/mediawiki-term-store

https://gerrit.wikimedia.org/r/507824

Change 507275 abandoned by Alaa Sarhan:
Add EntityTermsStoreSchemaAccess NormalizedTermStoreSchemaAccess interfaces

Reason:
Follow on https://github.com/wmde/mediawiki-term-store

https://gerrit.wikimedia.org/r/507275

Change 507276 abandoned by Alaa Sarhan:
Add InMemorySchemaAccess test helper class

Reason:
Follow on https://github.com/wmde/mediawiki-term-store

https://gerrit.wikimedia.org/r/507276

Change 507277 abandoned by Alaa Sarhan:
Add MediaWikiDatabaseNormalizedTermStore implementation of NormalizedTermStoreSchemaAccess.

Reason:
Follow on https://github.com/wmde/mediawiki-term-store

https://gerrit.wikimedia.org/r/507277

alaa_wmde updated the task description. (Show Details)May 6 2019, 7:53 PM
alaa_wmde closed this task as Invalid.May 29 2019, 8:13 AM

Duplicate of T224504