Page MenuHomePhabricator

Homepage: recent questions asked in same minute are indistinguishable
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:

Using either the mentorship module or help module on the homepage, ask two questions in quick succession (during the same calendar minute). Then go to the page where the question is and undo one of the questions. Return to the homepage and observe that neither of the questions appear archived. You can also observe that if you click one of the links, the link anchors to the first header (since the headers are identical).

Actual Results:

Both of the links appear archived when they are both archived, but if one is archived, neither appear archived.

Expected Results:

The links are treated independently, just like links that are not asked during the same calendar minute. If the best way to make this work is with the headers, we can talk about how to make headers unique, perhaps by including a snippet of the question text or something like that.

Note: it is not important to address this before the May 2 release.

Event Timeline

kostajh claimed this task.May 1 2019, 3:46 PM
kostajh moved this task from Incoming to In Progress on the Growth-Team (Current Sprint) board.

Also affects the help panel.

kostajh removed kostajh as the assignee of this task.May 1 2019, 6:43 PM

I can come back to this later this week or next week unless someone else gets to it first.

My idea is that since we now have up to three most recent questions stored in the prefs, we should be able to provide a unique section header for homepage/help module/help panel questions posted within the same minute.

Change 507886 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/extensions/GrowthExperiments@master] Append number to prevent duplicate question headers

https://gerrit.wikimedia.org/r/507886

Change 507886 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Append number to prevent duplicate question headers

https://gerrit.wikimedia.org/r/507886

Etonkovidova closed this task as Resolved.May 17 2019, 3:36 PM

Checked in betalabs -