Page MenuHomePhabricator

Homepage: If a talkpage is archived by moving, it is not considered as archivation by the recent questions feature
Closed, ResolvedPublic

Description

Some Czech users archive talkpage by _moving it_ (using the Move interface), not by moving the content (and leaving the revisions where they are). This isn't considered as archivation by your recent questions feature.

Since users do not include redirects when moving these talk pages, we should display these questions as archived on the homepage. The link on the homepage won't take the user to their question, so archived is the appropriate state.

Event Timeline

Urbanecm created this task.Apr 30 2019, 4:56 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 30 2019, 4:56 PM
JTannerWMF added subscribers: kostajh, JTannerWMF.

@kostajh will look into this

kostajh claimed this task.Apr 30 2019, 6:27 PM
kostajh edited projects, added Growth-Team (Current Sprint); removed Growth-Team.
kostajh moved this task from Incoming to In Progress on the Growth-Team (Current Sprint) board.

To reproduce, post a question to your mentor's page. The link correctly takes you to User_talk:Mentor#SomeHeader. If someone then moves User_talk:Mentor to User_talk:MentorBlah the following occurs:

  • (1) if the page move happened with a redirect, then the link in the mentor module will navigate to the moved page and to the correct heading
  • (2) if the page move happened without a redirect, the user is taken to User_talk:Mentor and they won't find their question

In scenario 1, from a terminology perspective one could argue that the link in the homepage mentor module should now say "archived" since User_talk:Mentor was moved to User_talk:MentorBlah. But from a product perspective I think "archived" is supposed to express that conversations can't happen on that question any longer (it was reverted, edited, etc). So I'm not sure we need to do anything for this scenario, since the question can still be responded to, and the poster and mentor can interact on the new page without issue.

For scenario 2, it would be nice if the recent questions feature could figure out that the result URL is no longer valid. I'm not sure we need to do anything about this though, as the places we are posting (mentor talk pages and help desk) could be informed to add redirects if they need to move their pages.

Further, we know that in kowiki the help desk taht users post to has a monthly archive. A user posting to help desk via help panel or the help module on the homepage will be posting to 위키백과:질문방/2019년_5월 (the page setup for the month) and not 위키백과:질문방 (the main landing page for the help desk). Because 위키백과:질문방/2019년_5월 is not going to be moved, I don't think we have to worry about scenario 1 or 2 above.

cc @SBisson, @Catrope and @MMiller_WMF for their review.

@Urbanecm -- thanks for continuing to test and think about the homepage. In what scenarios do people tend to move talkpages in the way you describe? Is it common?

@kostajh -- either way, we do not need to address this for May 2. It can be addressed later.

Urbanecm added a comment.EditedMay 1 2019, 6:48 AM

@Urbanecm -- thanks for continuing to test and think about the homepage. In what scenarios do people tend to move talkpages in the way you describe? Is it common?

In case they want to archive their talk page. They simply move User talk:Mentor to User talk:Mentor/Archive01 and then re-init their talkpage with a header they usually have at the top of their talkpage. A real example is https://cs.wikipedia.org/w/index.php?diff=17056095. I would say 80 % of wikipedians archive talkpages "normally" (by copy-pasting the content to the archive page) and 20 % archives talkpage by moving.

@kostajh -- either way, we do not need to address this for May 2. It can be addressed later.

That's of course up to you to decide. For your information, one of currently signed-up mentors (User:Vojtěch Veselý) does exactly this kind of archiving, see https://cs.wikipedia.org/w/index.php?diff=16822617.

To reproduce, post a question to your mentor's page. The link correctly takes you to User_talk:Mentor#SomeHeader. If someone then moves User_talk:Mentor to User_talk:MentorBlah the following occurs:

  • (1) if the page move happened with a redirect, then the link in the mentor module will navigate to the moved page and to the correct heading
  • (2) if the page move happened without a redirect, the user is taken to User_talk:Mentor and they won't find their question

In scenario 1, from a terminology perspective one could argue that the link in the homepage mentor module should now say "archived" since User_talk:Mentor was moved to User_talk:MentorBlah. But from a product perspective I think "archived" is supposed to express that conversations can't happen on that question any longer (it was reverted, edited, etc). So I'm not sure we need to do anything for this scenario, since the question can still be responded to, and the poster and mentor can interact on the new page without issue.

For the only usage of moving talk pages I know about (archiving), those who decide to archive by moving immediately after moving the talk page replaces the redirect with some init of their new talk page. This will break the links too.

Also, since the move is performed in order to archive talk page, I really think move should cause the q to be displayed as archived. Technically, you can edit the archive page, but that's the same for both archiving by moving and archiving by copypasting.

For scenario 2, it would be nice if the recent questions feature could figure out that the result URL is no longer valid. I'm not sure we need to do anything about this though, as the places we are posting (mentor talk pages and help desk) could be informed to add redirects if they need to move their pages.
Further, we know that in kowiki the help desk taht users post to has a monthly archive. A user posting to help desk via help panel or the help module on the homepage will be posting to 위키백과:질문방/2019년_5월 (the page setup for the month) and not 위키백과:질문방 (the main landing page for the help desk). Because 위키백과:질문방/2019년_5월 is not going to be moved, I don't think we have to worry about scenario 1 or 2 above.
cc @SBisson, @Catrope and @MMiller_WMF for their review.

Urbanecm renamed this task from Homepage: If a talkpage is archived by moving, it is not considered as archivation by your recent questions feature to Homepage: If a talkpage is archived by moving, it is not considered as archivation by the recent questions feature.May 1 2019, 4:13 PM
kostajh removed kostajh as the assignee of this task.May 1 2019, 5:23 PM

Moving and unassigning until the specifications are finalized.

I think we should consider these questions as "archived" when displaying them on the homepage. @kostajh, what is our current logic for whether to consider something archived? Are we trying to follow the link and seeing if it leads where it says it does? Or something else?

what is our current logic for whether to consider something archived? Are we trying to follow the link and seeing if it leads where it says it does? Or something else?

We look to see if 1) the revision is "visible" (not deleted) and 2) if the section header from the question can be found on the latest revision of the page the question was posted to.

MMiller_WMF removed MMiller_WMF as the assignee of this task.Jun 7 2019, 8:11 PM
MMiller_WMF updated the task description. (Show Details)

I changed the specifications to say that we should consider these questions as archived. This is ready for development.

Since users do not include redirects when moving these talk pages, we should display these questions as archived on the homepage.

@MMiller_WMF @Urbanecm if a redirect is created when the talk page is moved, should the question be considered archived?

In other words, the spec for this task is:

  1. If the mentor talk page or the help desk page is moved /without/ a redirect, then any questions should be marked as archived
  2. if the mentor talk page or the help desk page is moved /with/ a redirect, then questions should not be marked as archived
Tgr added a subscriber: Tgr.Aug 20 2019, 1:02 PM

The one situation where redirecting a talk page and leaving that redirect in place is user rename (which happens but is very rare). In that case, we can either accept that the module will incorrectly say archived (doesn't seem like a big deal), or we have to detect whether the question has been archived from the new (redirected) talk page - showing it as not archived when in reality it has been doesn't seem any better than the original situation.

Tgr added a comment.Aug 20 2019, 1:25 PM

There are two ways to do this:

  • Assume a mentor question is archived if it is on a subpage (not the main user talk page). Ignore the help desk (and hope no one does archive-by-move there).
  • Parse the result URL back into a title. Assume the question is archived if the stored and actual title do not match. (This will erroneously claim the question is archived on user rename and such, but those are very rare.)
Tgr claimed this task.Aug 20 2019, 1:26 PM

Change 531283 had a related patch set uploaded (by Gergő Tisza; owner: Gergő Tisza):
[mediawiki/extensions/GrowthExperiments@master] QuestionStore: Consider an answer archived if the URL has changed

https://gerrit.wikimedia.org/r/531283

Done as per spec, but I'm ambivalent about this. On one hand, when the page is move-archived after the question has been answered, permalinking to the revision in which the question was asked is not really helpful - the user won't see the answer, and we could easily link to the new location instead. On the other hand, that would make the behavior inconsistent since there's no way to do that for copy-archiving (but then users only have one mentor who probably has consistent archiving practices so maybe that inconsistency doesn't really matter?) and it somewhat guides users towards breaking social norms (you are not supposed to edit an archived page).

Change 531283 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] QuestionStore: Consider an answer archived if the URL has changed

https://gerrit.wikimedia.org/r/531283

@MMiller_WMF please review the current behavior for archived mentor User talk page. Being "archived" is defined as moving the page to a subpage in the user talk page, as @Urbanecm mentioned in the comment - moving User talk:Mentor to User talk:Mentor/Archive01.

(1) Moving with leaving redirect

  • all links - "View your mentor's other conversations", archived questions, and questions posted after User talk:Mentor page was archived, notifications links will direct to the archived page - e.g. User talk:Mentor/Archive01.
  • newly posted questions will be posted on a automatically recreated User talk:Mentor page but the link for a question posted on that new page -"View your question on a mentor page" will still redirect to User talk:Mentor/Archive01.

There is a way to see new User talk:Mentor page with either to click on an archived page link after Redirected from User talk:Mentor or to modify the url to https://en.wikipedia.beta.wmflabs.org/w/index.php?title=User_Mentor&redirect=no.

(2) Redirect suppressed
Works completely logical - the links for archived questions will direct to an archived page; new questions will be posted and their link redirect to a new User talk:Mentor page.

MMiller_WMF closed this task as Resolved.Sat, Sep 21, 12:41 AM

Sounds good -- thank you!