Page MenuHomePhabricator

"Find" doesn't scroll the viewport
Closed, ResolvedPublic

Description

First, I found the part of the page that I wanted. Then, I closed the Find panel. The visual editor scrolled me to the top of the page (lost focus?). I clicked into the page (to make sure that the cursor was somewhere sensible) and opened the Find panel. Now, it cycles through the numbers – I wouldn't be surprised if the cursor really were at #1 out of 5, and then #2 out of 5, etc. – but I don't see what I want. I only see the top of the article.

Details

Related Gerrit Patches:
mediawiki/extensions/VisualEditor : masterUpdate VE core submodule to master (67f50262e)
VisualEditor/VisualEditor : masterFix find and replace selection handling

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 1 2019, 3:45 AM
marcella added a subscriber: marcella.

Investigate as possible regression due to selection work.

DLynch added a subscriber: DLynch.May 8 2019, 4:55 PM

I can't reproduce it not scrolling while the find panel is open, but the jump to the top when the find panel closes is definitely there.

It also only happens on Mediawiki. In standalone VE the scroll position is maintained. (Which is a pain, because there's been enough breaking changes lately that bisecting the submodule is awkward.)

I would imagine if you disable "null selection on blur" in standalone it will behave like MW.

Change 512655 had a related patch set uploaded (by Esanders; owner: Esanders):
[VisualEditor/VisualEditor@master] Fix find and replace selection handling

https://gerrit.wikimedia.org/r/512655

Esanders moved this task from Incoming to Code review on the VisualEditor (Current work) board.

Change 512655 merged by jenkins-bot:
[VisualEditor/VisualEditor@master] Fix find and replace selection handling

https://gerrit.wikimedia.org/r/512655

Change 513019 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (67f50262e)

https://gerrit.wikimedia.org/r/513019

Change 513019 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (67f50262e)

https://gerrit.wikimedia.org/r/513019

ppelberg closed this task as Resolved.Jul 19 2019, 2:09 AM