Page MenuHomePhabricator

ores-support-checklist is down
Closed, ResolvedPublic

Event Timeline

Halfak created this task.May 1 2019, 3:14 PM
Restricted Application added a project: User-Ladsgroup. · View Herald TranscriptMay 1 2019, 3:14 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Halfak triaged this task as High priority.May 1 2019, 3:15 PM

Marking this high instead of "unbreak" because it's not a critical service and only serves informational needs.

Halfak added a comment.May 1 2019, 3:25 PM

I found this at the end of the uwsgi.log:

Python version: 3.4.2 (default, Feb  7 2019, 06:11:23)  [GCC 4.9.2]
Set PythonHome to /data/project/ores-support-checklist/www/python/venv
Fatal Python error: Py_Initialize: Unable to get the locale encoding
ImportError: No module named 'encodings'
!!! uWSGI process 1 got Segmentation Fault !!!
*** backtrace of 1 ***
/usr/bin/uwsgi(uwsgi_backtrace+0x30) [0x4635f0]
/usr/bin/uwsgi(uwsgi_segfault+0x21) [0x4639b1]
/lib/x86_64-linux-gnu/libc.so.6(+0x350e0) [0x7f2c858690e0]
/lib/x86_64-linux-gnu/libc.so.6(abort+0x232) [0x7f2c8586a532]
/usr/lib/x86_64-linux-gnu/libpython3.4m.so.1.0(Py_FatalError+0x50) [0x7f2c840ec980]
/usr/lib/x86_64-linux-gnu/libpython3.4m.so.1.0(+0x1963cb) [0x7f2c840ed3cb]
/usr/lib/x86_64-linux-gnu/libpython3.4m.so.1.0(_Py_InitializeEx_Private+0x23a) [0x7f2c840edb3a]
/usr/lib/uwsgi/plugins/python3_plugin.so(uwsgi_python_init+0x101) [0x7f2c847a92a1]
/usr/bin/uwsgi(uwsgi_start+0x51e) [0x464bee]
/usr/bin/uwsgi(uwsgi_setup+0x1073) [0x466c33]
/usr/bin/uwsgi(main+0x9) [0x416999]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5) [0x7f2c85855b45]
/usr/bin/uwsgi() [0x4169c7]
*** end of backtrace ***
Halfak added a comment.May 1 2019, 3:27 PM

I can run the venv and import "encodings"

(venv) tools.ores-support-checklist@tools-sgebastion-08:~/www/python$ python
Python 3.5.3 (default, Sep 27 2018, 17:25:39) 
[GCC 6.3.0 20170516] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import encodings
>>>

Note that the python version is different in the log compared to when I run the venv. I wonder why.

I usually just restart the webservice, maybe it's better to take it out kubernetes cluster:

webservice stop
webservice python start
Halfak claimed this task.May 13 2019, 4:18 PM
Halfak added a subscriber: Ladsgroup.

I rebuilt the python virtualenv and restarted the web service. Looks like the issue is resolved.

Halfak closed this task as Resolved.Tue, Jun 18, 1:39 PM