Page MenuHomePhabricator

Special:Search generates "TypeError: this.pushPending is not a function"
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:

In the JavaScript console the error

TypeError: this.pushPending is not a function

is reported.

This problem happens since rMW8414e3c4d0c2: Update OOUI to v0.31.4 (@Jdforrester-WMF @Volker_E).

Event Timeline

Fomafix created this task.May 2 2019, 5:07 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 2 2019, 5:07 AM
Fomafix updated the task description. (Show Details)May 2 2019, 5:10 AM
Fomafix added a subscriber: Volker_E.

Tentatively setting T220728 as parent task. Please feel free to correct me.

thcipriani triaged this task as Unbreak Now! priority.May 2 2019, 3:32 PM
thcipriani added a subscriber: thcipriani.

Tentatively setting T220728 as parent task. Please feel free to correct me.

Setting as unbreak now since this is a train blocker. Would also like other opinions here: @Jdforrester-WMF ?

Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptMay 2 2019, 3:32 PM

Seems to be caused by patch for T220204.

Jdforrester-WMF lowered the priority of this task from Unbreak Now! to High.May 2 2019, 3:58 PM

Tentatively setting T220728 as parent task. Please feel free to correct me.

Setting as unbreak now since this is a train blocker. Would also like other opinions here: @Jdforrester-WMF ?

I don't think this is a train blocker. JS error and loss of "pending" styling are the only outcomes. De-tagging.

Restricted Application added a project: Discovery-Search. · View Herald TranscriptMay 2 2019, 3:58 PM

Exposed by OOUI, but is a downstream issue.

Change 507823 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/core@master] SearchInputWidget: Replace pushPending hack

https://gerrit.wikimedia.org/r/507823

Change 507823 merged by jenkins-bot:
[mediawiki/core@master] SearchInputWidget: Replace pushPending hack

https://gerrit.wikimedia.org/r/507823

Change 507863 had a related patch set uploaded (by Jforrester; owner: Esanders):
[mediawiki/core@wmf/1.34.0-wmf.3] SearchInputWidget: Replace pushPending hack

https://gerrit.wikimedia.org/r/507863

Change 507863 merged by jenkins-bot:
[mediawiki/core@wmf/1.34.0-wmf.3] SearchInputWidget: Replace pushPending hack

https://gerrit.wikimedia.org/r/507863

Mentioned in SAL (#wikimedia-operations) [2019-05-02T19:39:44Z] <jforrester@deploy1001> Synchronized php-1.34.0-wmf.3/includes/widget/SearchInputWidget.php: Hot-deploy T222329 fix part 1 (duration: 00m 53s)

Mentioned in SAL (#wikimedia-operations) [2019-05-02T19:40:54Z] <jforrester@deploy1001> Synchronized php-1.34.0-wmf.3/resources/src/mediawiki.widgets/mw.widgets.SearchInputWidget.js: Hot-deploy T222329 fix part 2 (duration: 00m 50s)

Jdforrester-WMF closed this task as Resolved.May 2 2019, 7:41 PM
Jdforrester-WMF assigned this task to Esanders.

Now deployed.