Page MenuHomePhabricator

[subtask] Regression: In the mobile version of Special:RecentChanges, "(diff | hist)" is shown as "diffhist"
Closed, ResolvedPublicBug

Description

Steps to Reproduce:

1.Open zhwiki/enwiki; e.g. https://en.m.wikipedia.org/wiki/Special:RecentChanges
2.Switch to mobile view
3.Goto Special:RecentChanges

Actual Results:

diffhist
Nikolai Latysh‎; 04:02 +147‎ ‎Geregen2 talk contribs‎

Expected Results:

(diff|hist) Nikolai Latysh‎; 04:02 (+147‎) ‎Geregen2 (talk|contribs‎)

QA steps

Confirm on https://en.m.wikipedia.beta.wmflabs.org/wiki/Special:RecentChanges that diff and hist links are separated and do not look like this:

QA Results

StatusDetails
✅ PassedT222394#5166347

Event Timeline

Restricted Application added subscribers: Cosine02, Aklapper. · View Herald TranscriptMay 2 2019, 8:10 PM
Aklapper renamed this task from Vanishing symbols in RC (of zhwiki, enwiki) to In the mobile version of Special:RecentChanges, "(diff | hist)" is shown as "diffhist".May 2 2019, 8:55 PM
Aklapper triaged this task as High priority.
Restricted Application added a project: Growth-Team. · View Herald TranscriptMay 2 2019, 8:55 PM
Jdlrobson added subscribers: Jdrewniak, Jdlrobson.

@Jdrewniak Ic57cb79903e90ce1bbfa6d87ab0499f09373e732 would have reset these styles (and all other special pages using changelist)
Will https://gerrit.wikimedia.org/r/505769 restore this?

Jdlrobson renamed this task from In the mobile version of Special:RecentChanges, "(diff | hist)" is shown as "diffhist" to Regression: In the mobile version of Special:RecentChanges, "(diff | hist)" is shown as "diffhist".May 2 2019, 9:06 PM
Jdlrobson updated the task description. (Show Details)
Jdlrobson moved this task from Incoming to Needs Prioritization on the Readers-Web-Backlog board.

@Jdlrobson it could. We would just have to pull out the following rule from being history-page specific and place it somewhere more generic.

.mw-history-histlinks.mw-changeslist-links {
	& > span:before {
		content: '(';
	}
	& > span:not( :first-child ):before {
		content: ' | ';
	}
	& > span:last-child:after {
		content: ')';
	}
}
Jdlrobson renamed this task from Regression: In the mobile version of Special:RecentChanges, "(diff | hist)" is shown as "diffhist" to [subtask] Regression: In the mobile version of Special:RecentChanges, "(diff | hist)" is shown as "diffhist".May 2 2019, 11:13 PM

Given this was caused by a task currently in the sprint (T219895), I think it makes sense to fix this as part of the sprint, either via reverting or applying the suggested CSS from @Jdrewniak to the mediawiki.interface.helpers.styles module

Change 508572 had a related patch set uploaded (by Jdrewniak; owner: Jdrewniak):
[mediawiki/skins/MinervaNeue@master] Add Minerva specific mediawiki.interface.helpers.styles.less file

https://gerrit.wikimedia.org/r/508572

Change 508572 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@master] Add Minerva specific mediawiki.interface.helpers.styles.less file

https://gerrit.wikimedia.org/r/508572

DWYoungDLS added a comment.EditedMay 7 2019, 5:02 PM

The new fixing do fixed some brackets. But, unfortunately, the edit summary, the page size changing and the edit tag should be covered with brackets too.

The new fixing do fixed some brackets. But, unfortunately, the edit summary, the page size changing and the edit tag should be covered with brackets too.

We are currently in the process of redesigning this and other special pages in the mobile skin, starting with the history page, so this is by design. You can follow progress in T219895.

Test Result

Status: ✅ PASS
OS: macOS Mojave
Browser: Chrome
Device: MBP
Emulated Device: iPhoneX

Test Artifact(s):

Edtadros assigned this task to ovasileva.May 8 2019, 8:23 AM
Edtadros updated the task description. (Show Details)

Should this be tagged with the Audiences-RW test case tag? I wasn't sure since this was a bug.

ovasileva closed this task as Resolved.May 8 2019, 9:59 AM

Should this be tagged with the Audiences-RW test case tag? I wasn't sure since this was a bug.

Resolving! Adding the tag in case we need to retest for AMC