Page MenuHomePhabricator

Page notices hidden behind toolbar dialogs
Closed, ResolvedPublic

Description

Steps to reproduce:

  1. Open a page that will show a notice in VE (e.g. old version of a page, protected page, etc.)
  2. Open a toolbar dialog while the notice is still shown (e.g. press Crtl+F, or open the special characters and manually show the notice again.)

Expected result:
The notice should be above the dialog.

Actual result:
The content of the dialog is shown above the notice, partially obscuring it in a strange way.

Event Timeline

Schnark created this task.May 3 2019, 8:26 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 3 2019, 8:26 AM

This is basically the same issue as T221705. Looks like the patch for that task did not fix this, because the z-index: 1; is overriden to 4 in another place.

Change 508394 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[oojs/ui@master] PopupTool: Fix popup z-index override

https://gerrit.wikimedia.org/r/508394

Change 508394 merged by jenkins-bot:
[oojs/ui@master] PopupTool: Fix popup z-index override

https://gerrit.wikimedia.org/r/508394

Change 508807 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[mediawiki/core@master] Update OOUI to v0.31.6

https://gerrit.wikimedia.org/r/508807

Change 508807 merged by jenkins-bot:
[mediawiki/core@master] Update OOUI to v0.31.6

https://gerrit.wikimedia.org/r/508807

ppelberg closed this task as Resolved.Jul 3 2019, 3:11 AM
ppelberg claimed this task.