Page MenuHomePhabricator

building of wikibase 1.31 fails in Docker due to newer ca-certificates package
Closed, DeclinedPublic3 Story PointsBug

Description

Steps to Reproduce:
download the following
https://github.com/dbs/wikibase-docker/archive/wikibase-1.31.zip
run
docker build -t wikibase/wikibase:1.31 wikibase/1.31/base/
and then

docker-compose -f docker-compose-build.yml build

Actual Results:
the previous command halts with the following error

Step 8/19 : RUN apk --no-cache add --virtual build-dependencies ca-certificates~=20171114 git~=2.20 nodejs~=10.14 npm~=10.14 jq~=1.6
---> Running in ab65aad550e7
fetch http://dl-cdn.alpinelinux.org/alpine/v3.9/main/x86_64/APKINDEX.tar.gz
fetch http://dl-cdn.alpinelinux.org/alpine/v3.9/community/x86_64/APKINDEX.tar.gz
ERROR: unsatisfiable constraints:

ca-certificates-20190108-r0:
  breaks: build-dependencies-0[ca-certificates~20171114]
  satisfies: nodejs-10.14.2-r0[ca-certificates]
             libcurl-7.64.0-r1[ca-certificates]

ERROR: Service 'wdqs-frontend' failed to build: The command '/bin/sh -c apk --no-cache add --virtual build-dependencies ca-certificates~=20171114 git~=2.20 nodejs~=10.14 npm~=10.14 jq~=1.6' returned a non-zero code: 6

Expected Results:
the image is successfully built

(I'm running Docker 18.09.3 on Centos 7.5)

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 4 2019, 11:33 AM
Aklapper renamed this task from building of wikibase 1.31 fails to building of wikibase 1.31 fails in Docker due to newer ca-certificates package.May 4 2019, 6:31 PM
WMDE-leszek set the point value for this task to 3.May 14 2019, 12:41 PM
Restricted Application added a project: User-Ladsgroup. · View Herald TranscriptMay 14 2019, 2:31 PM
Ladsgroup added a comment.EditedMay 14 2019, 3:11 PM

@Topway.it I tried to reproduce this but I couldn't. The only thing that caught my eyes was that you are downloading wikibase docker image from a fork that doesn't belong to us (https://github.com/dbs/wikibase-docker/). You should download it from https://codeload.github.com/wmde/wikibase-docker/zip/master instead. Would it solve your issue?

In most situations you will just want to pull the image from Docker hub rather than building it yourself too.
Unless you want to make modifications to the build.

https://hub.docker.com/r/wikibase/wikibase

WMDE-leszek closed this task as Declined.May 16 2019, 10:17 AM
WMDE-leszek added a subscriber: WMDE-leszek.

@Topway.it feel free to reopen if above suggestions, including updating your fork don't help. It seems to us the problem is no longer a case in the current state of the Docker repo.

Topway.it reopened this task as Open.EditedJun 16 2019, 2:58 AM

Hello, I've tried to download from https://github.com/dbs/wikibase-docker/
and it works. *** ATTENTION, here there was a mistake, the correct url for the repository that works is the following:
https://github.com/wmde/wikibase-docker/blob/master/

I apologize for that

However, I have still the issue described here

https://phabricator.wikimedia.org/T222503

item properties don't show in menu. (the list is empty)

do you have any hint ?
thanks
(Thomas)

Addshore closed this task as Declined.Jun 16 2019, 4:20 PM

Hello, I've tried to download from https://github.com/dbs/wikibase-docker/
and it works.

If you want to download the Dockerfiles please use https://github.com/wmde/wikibase-docker
This is our repo.

The best thing to do is just download the built images from docker hub.
https://hub.docker.com/u/wikibase

However, I have still the issue described here
https://phabricator.wikimedia.org/T222503
item properties don't show in menu. (the list is empty)
do you have any hint ?
thanks
(Thomas)

If you are having the issue described in T222503 then lets discuss that there rather than here.

Adding to what @Addshore mentioned above, note that github hints that the "dbs" fork is quite behind the upstream, WMDE-provided, images: "This branch is 46 commits behind wmde:master. "
This makes it significantly harder to reason about, given we're talking some non-current version of images. Given the limited resources we all have, we'd rather focus on issues in the current upstream version. We hope you understand this being a reason to decline the bug report for us.

Hello, I have now edited the post created on Sun, Jun 16, 2:58 AM
because actually the repository which worked is this one

https://github.com/wmde/wikibase-docker/blob/master

regarding the issue related to item properties, I've reported the issue
because I have assumed that a clean installation of wikibase comes
with the existing properties you can find on wikidata, but actually
it is not so.
So even this bug report can be removed.
Thanks a lot