Page MenuHomePhabricator

OAuth login just redirects to MediaWiki authenticate endpoint again and agian
Closed, ResolvedPublic

Description

Summary of investigation

I've updated my /etc/hosts to force tracker2.wikimedia.cz to go to 127.0.0.1. I've then configured my localhost Apache to act as a reverse proxy and forward all traffic going to tracker2.wikimedia.cz to localhost:8000 (that's where the development instance of Tracker is running). This was done to be able to use real tracker2.wikimedia.cz OAuth consumer to debug the issue in localhost environment. I've then changed OAuth consumer tokens in settings.py to 99be4b77991ee5e7f2fc034387aead3e (the tracker2.wikimedia.cz consumer). The issue persisted. However, when I changed the tokens back to the localhost one, the issue no longer appeared.

Original task description

See https://ctrlv.tv/SAAy. This is happening only on production, not with localhost tokens.

Event Timeline

Urbanecm triaged this task as High priority.May 5 2019, 12:24 AM
Urbanecm created this task.
Urbanecm updated the task description. (Show Details)
Urbanecm claimed this task.May 5 2019, 12:31 AM

I've changed the OAuth tokens to the previous ones (without Access to private information permission), it started to work smoothly. The test instance (tracker2.wikimedia.cz) still has the updated tokens. Will investigate tomorrow.

Restricted Application added a project: User-Urbanecm. · View Herald TranscriptMay 5 2019, 12:32 AM
Urbanecm updated the task description. (Show Details)May 5 2019, 8:21 PM
Urbanecm closed this task as Resolved.May 5 2019, 8:58 PM

Stupid mistake, had bad callback in Oauth registration :(.