Page MenuHomePhabricator

Special:ChangeContentModel shows errors before the form is submitted
Open, Needs TriagePublic

Description

Special:ChangeContentModel shows the "There are problems with some of your input." (htmlform-invalid-input) and "This value is required." (htmlform-required) errors before the form is submitted. These errors should only display after trying to submit the form without a title.

Original report:

Some user that writes help pages on bsWiki reported he needs "sanitized css" for some pages. The thing is it is not possible for me to access that page as non-admin. Current admins reported message "There are problems with your entry".

Site that needs changed parameter is: [[:bs: Posebno:ChangeContentModel]]

Thanks in advance

Event Timeline

Munja created this task.May 5 2019, 10:38 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 5 2019, 10:38 AM
Ammarpad added a subscriber: Ammarpad.

Non-admins cannot change contentmodel of a page, that works as it should. Can you clarify on the error message seen by the admin who tried to access https://bs.wikipedia.org/wiki/Special:ChangeContentModel? Or possibly ask them to upload a screenshot?

Munja added a comment.May 5 2019, 11:16 AM

Non-admins cannot change contentmodel of a page, that works as it should. Can you clarify on the error message seen by the admin who tried to access https://bs.wikipedia.org/wiki/Special:ChangeContentModel? Or possible ask them to upload a screenshot?

Here's the screenshot: https://bs.wikipedia.org/wiki/Datoteka:Aufzeichnen.JPG

Translation:
There are some problems with your entry
Page name
This value is required

Hi @Munja, thanks for taking the time to report this! Unfortunately this report lacks information. If you have time and can still reproduce the problem: Please add a more complete description to this report: A clear list of specific steps to reproduce the situation, so that nobody needs to guess how you performed each step, and providing a link to a website where the issue can be seen. You can edit the task description by clicking Edit Task.
Ideally, exact and clear steps to reproduce should allow any other person to follow these steps (without having to interpret those steps) and see the same results. Problems that others can reliably reproduce can get fixed faster. Thanks!

I am administrator on Serbian Wikipedia and when I go at https://sr.wikipedia.org/wiki/Special:ChangeContentModel I get same message which @Munja provided at T222535#5158033.
And it is correct because administrator didn't specify page for which he want to change content model.

But we should disable showing this message per default when admin access to page and it should be showed only when he doesn't specify name of page and click on button, no before it.

On bswiki I get message to I can't access because I am not administrator:

Here's the screenshot: https://bs.wikipedia.org/wiki/Datoteka:Aufzeichnen.JPG
Translation:
There are some problems with your entry
Page name
This value is required

The page name is required. Meaning that you've to prefill the input box with the name of the page you want change its contentmodel. It appears you're just leaving it blank.

Here's the screenshot: https://bs.wikipedia.org/wiki/Datoteka:Aufzeichnen.JPG
Translation:
There are some problems with your entry
Page name
This value is required

The page name is required. Meaning that you've to prefill the input box with the name of the page you want change its contentmodel. It appears you're just leaving it blank.

It looks so.

JJMC89 added a subscriber: JJMC89.May 5 2019, 5:09 PM

I don't think it should show those errors unless you press change without providing a title.

Munja added a comment.May 5 2019, 5:12 PM

I don't think it should show those errors unless you press change without providing a title.

I did not change because I have not permission - because unfortunately I am not an admin. Fortunately, it has been finished after we asked administrator on our Wikipedia to provide screenshots after every operation we instructed.

Thanks again to team who helped. This should be case closed.

Munja closed this task as Resolved.May 5 2019, 5:12 PM
Munja triaged this task as Lowest priority.
Zoranzoki21 changed the task status from Resolved to Invalid.May 5 2019, 5:15 PM
Zoranzoki21 raised the priority of this task from Lowest to Needs Triage.

Nothing changed in code so this task should be closed as invalid..

JJMC89 renamed this task from ChangeContentModel on bs.Wikipedia // Sanitized CSS to Special:ChangeContentModel shows errors before the form is submitted.May 5 2019, 5:15 PM
JJMC89 reopened this task as Open.
JJMC89 updated the task description. (Show Details)

I don't think it should show those errors unless you press change without providing a title.

I've repurposed this ticket accordingly.

I don't think it should show those errors unless you press change without providing a title.

I've repurposed this ticket accordingly.

Good. I was thinking of opening a separate ticket, but this works fine.

Ammarpad updated the task description. (Show Details)May 5 2019, 7:05 PM
Munja removed a subscriber: Munja.May 5 2019, 7:05 PM

@Ammarpad before I open a task about CiteThisPage having the same error, is there already such a task?