Page MenuHomePhabricator

Call to undefined method SprintProjectProfilePanelEngine::buildNavigation() when accessing Burndown since 2019.16
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:
Created a new project and set "Is Sprint" & when clicking "Burndown" it will display "Call to undefined method SprintProjectProfilePanelEngine::buildNavigation() "


phabricator edda40aa3b931ed064c52536af5b65fd6611e841 (Tue, Apr 23) (branched from 02cfcfa0796993e078c8cb632a9df39ef7227e46 on origin) arcanist 4d22e0f89f10b8a7f47f6ee615e0ccf0f354e582 (Mar 8 2019) (branched from 9830c9316d38988b2dc283ac1a124b73bc8e6c5f on origin) phutil 3e6a9946bcfc39591dbd9a571d1f56c8c27d4a0a (Thu, Apr 18) (branched from 639e4b9cae284717b1ed717dd1e4d11c70744b86 on origin) sprint 9da8f6c3f27282aa10375bb97592cbe86db99d24 (Nov 29 2017) php 7.1.28 diff 3.5 at /usr/bin/diff git 2.21.0 at /opt/bitnami/git/bin/git hg Not Available pygmentize Not Available svn 1.9.5 at /usr/bin/svn

Actual Results:

Expected Results:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 6 2019, 8:51 AM
Aklapper triaged this task as Lowest priority.May 6 2019, 11:20 AM

I have tracked the issue here: https://secure.phabricator.com/w/changelog/2019.16/
and more specifically here:
ProfileMenu: The ProfileMenu API has changed. If you have custom ProfileMenu item implementations, they will likely require minor updates. D20358 represents the bulk of the API changes: newNavigationMenuItems() has become newMenuItemViewList(), and newItem() is now newItemView(). These API changes support tracking the selection and highlight state of items in cases when a single ProfileMenu item produces multiple distinct controls in the menu. Today, there are no such upstream cases, but this made some of the other changes easier. See also D20357 for more discussion and rationale.

https://secure.phabricator.com/D20358

Aklapper renamed this task from Call to undefined method SprintProjectProfilePanelEngine::buildNavigation() - when accessing "Burndown" to Call to undefined method SprintProjectProfilePanelEngine::buildNavigation() when accessing Burndown since 2019.16.May 13 2019, 10:21 AM
Shed4 added a subscriber: Shed4.Jun 21 2019, 8:27 AM
Shed4 added a comment.Jun 21 2019, 8:36 AM

@Aklapper Also suffering from the problem here. Is there any workaround or maybe some patch to test?

@Shed4: The workaround would be someone to take a look at the previous comment and fix the code. As https://phabricator.wikimedia.org/tag/phabricator-sprint-extension/ says, this project is unmaintained. Your contributed patch is welcome.

Just got a head-up from Alves Logo Michael (kairel) with a fix that I merged in my fork https://github.com/vlaza/phabricator-extensions-Sprint

Check out his commit about the fix.

https://github.com/kairel/phabricator-extensions-Sprint/commit/0d77d94a351ad2e38d8f097bf8f2146ff6369797

Vlaza-servoy-com closed this task as Resolved.Jun 25 2019, 1:59 PM
Vlaza-servoy-com claimed this task.
Vlaza-servoy-com moved this task from Backlog to Review on the Phabricator-Sprint-Extension board.