Page MenuHomePhabricator

EntitySchema\Tests\DataAccess\ArrayRevisionLookup must be compatible with RevisionLookup
Closed, ResolvedPublic

Description

Currently EntitySchema tests yield:

08:55:35 Fatal error: Declaration of EntitySchema\Tests\DataAccess\ArrayRevisionLookup::getPreviousRevision() must be compatible with that of MediaWiki\Revision\RevisionLookup::getPreviousRevision() in /workspace/src/extensions/EntitySchema/tests/phpunit/DataAccess/ArrayRevisionLookup.php on line 16
(https://integration.wikimedia.org/ci/job/quibble-vendor-mysql-hhvm-docker/47529/console)

Event Timeline

hoo created this task.May 6 2019, 9:56 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 6 2019, 9:56 AM

Change 508297 had a related patch set uploaded (by Hoo man; owner: Hoo man):
[mediawiki/extensions/EntitySchema@master] Adapt ArrayRevisionLookup to RevisionLookup changes

https://gerrit.wikimedia.org/r/508297

Change 508297 merged by jenkins-bot:
[mediawiki/extensions/EntitySchema@master] Adapt ArrayRevisionLookup to RevisionLookup changes

https://gerrit.wikimedia.org/r/508297

This seem to have been fixed. Therefore closing this ticket. Feel free to re-open if I missed something.

Michael closed this task as Resolved.May 24 2019, 12:10 PM