In this situation it sounds like it would be better to bind against FingerprintProvider, as a FingerprintValidator is about to be used. So Fingerprint makes sense in the context, as the labels and descriptions need to be validated together.
However, FingerprintValidator is badly named, as it only actually validates label and description combinations, and doesn't validate a Fingerprint object, rather parts of it.
I would propose that we rename FingerprintValidator to LabelsDescriptionsValidator and then ChangeOps must bind against LabelsProvider and DescriptionsProvider which seems fine.
Acceptance criteria🏕️🌟:
- We have looked at and evaluated the TODO
- We have either removed the TODO (situation is okay right now), or we have implemented some change (if it doesn't require rewriting the world)