Page MenuHomePhabricator

OCR tool gives incorrect error message when it is over capacity
Closed, DeclinedPublicBUG REPORT

Description

Steps to Reproduce:

A number of OCR requests must already be in process.

Actual Results:

Trying to run this tool gives the error message: ws_ocr_daemon robot is not running. Please try again later.

Expected Results:

Instead, it should give an error message to the effect that the tool is too busy to accept any more requests at the present time.

See here for more details: https://en.wikisource.org/w/index.php?oldid=9244784#Requesting_the_activation_of_the_OCR_daemon

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 11 2019, 7:12 PM
Aklapper updated the task description. (Show Details)May 12 2019, 10:49 PM
Aklapper added a project: Tools.

@Peteforsyth: This tool seems to track its bug reports at https://github.com/phil-el/phetools/issues and not in Wikimedia Phabricator?

Even better solution would be if the tool could accept more requests so that the message was not needed anymore.

Phe added a subscriber: Phe.EditedMay 30 2019, 5:50 PM

The message is fine, the service was down and not running, those downtime are not related to 'too much request' but there was probably something broken in the past few days in the cluster or one of the numerous downtime for a planned maintenance. Anyway I restarted the service.

It is not running again. Is there any possibility how to improve the gadget's performance and make its inaccessibility less frequent, or ideally make it accessible at any time?

Ineuw added a subscriber: Ineuw.Jun 1 2019, 5:33 PM

@Phe, The same request as Jan.Kamenicek's above. Is it possible to implement the OCR locally?

Note, I don't think Phe is tracking this here. He responded only after I left a note on his github page, which Aklapper linked above.

Seems it works again. If @Phe has repaired it, I would like to thank him very much, as the tool is great help.

Aklapper closed this task as Declined.Jul 2 2019, 9:32 PM

Closing per last comment - this seems to be handled at https://github.com/phil-el/phetools/issues instead and is not reproducible anymore.