Page MenuHomePhabricator

enwp10 is returning 503 error
Closed, ResolvedPublic

Description

Example URL https://tools.wmflabs.org/enwp10/cgi-bin/list2.fcgi?run=yes&projecta=New_Zealand&importance=Top-Class&quality=FA-Class

Message is:
"No webservice

The URI you have requested, /enwp10/cgi-bin/list2.fcgi?run=yes&projecta=New_Zealand&importance=Top-Class&quality=FA-Class, is not currently serviced.

If you have reached this page from somewhere else...

This URI is part of the enwp10 tool, maintained by Audiodude Kelson .

That tool might not have a web interface, or it may currently be disabled.

If you're pretty sure this shouldn't be an error, you may wish to notify the tool's maintainers (above) about the error and how you ended up here.

If you maintain this tool

You have not enabled a web service for your tool, or it has stopped working because of a fatal error. Please check the error logs of your web service."

Event Timeline

Nurg created this task.May 12 2019, 1:52 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 12 2019, 1:52 AM

What happens with qstat, is that still available?

I get this error message which I think explains why I can not restart the webservice

$ webservice --backend=gridengine lighttpd restart
Traceback (most recent call last):
  File "/usr/bin/webservice", line 180, in <module>
    if job.get_state() != Backend.STATE_RUNNING:
  File "/usr/lib/python2.7/dist-packages/toollabs/webservice/backends/gridenginebackend.py", line 95, in get_state
    job = self._get_job_xml()
  File "/usr/lib/python2.7/dist-packages/toollabs/webservice/backends/gridenginebackend.py", line 57, in _get_job_xml
    output = subprocess.check_output(['qstat', '-xml'])
  File "/usr/lib/python2.7/subprocess.py", line 566, in check_output
    process = Popen(stdout=PIPE, *popenargs, **kwargs)
  File "/usr/lib/python2.7/subprocess.py", line 710, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/subprocess.py", line 1335, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory
``
Audiodude closed this task as Resolved.May 12 2019, 11:22 AM
Audiodude claimed this task.

Hi @Kelson , I think you gave extra parameters to your restart command. I tried:

$ webservice restart
Your job is not running, starting..........

And it seems to be working now.

Cheers,
-Travis

Nurg added a comment.May 12 2019, 11:25 AM

Confirmed it's ok now. Thank you.
Nurg