Page MenuHomePhabricator

Disable indexing by robots of user pages in Lao Wikipedia
Closed, InvalidPublic

Description

In the Wikipedia in Lao, subpages of userpages are open to robots of search engines. In other language versions this is not allowed (which makes much sense, because the general public don't wants to find user pages of wikipedians).

Steps to Reproduce:
Example page with the line: Indexing by robots = Allowed: https://lo.wikipedia.org/w/index.php?title=%E0%BA%9C%E0%BA%B9%E0%BB%89%E0%BB%83%E0%BA%8A%E0%BB%89:MimiVK99/%E0%BA%9E%E0%BA%B0%E0%BA%A5%E0%BA%B1%E0%BA%87%E0%BA%87%E0%BA%B2%E0%BA%99%E0%BB%81%E0%BA%9A%E0%BA%9A%E0%BA%8D%E0%BA%B7%E0%BA%99%E0%BA%8D%E0%BA%BB%E0%BA%87_(Sustainable_energy)&action=info

Actual Results:
Search engines like Google show these Userpages on top of their result list.

Expected Results:
Search engines should show only WP articles and not user pages or user sub pages.

For info: I had asked the question here
https://meta.wikimedia.org/wiki/Steward_requests/Miscellaneous#Lao_Wikipedia:_Indexing_by_robots_of_user_pages

Thank you for fixing this.

Event Timeline

Hadi created this task.May 12 2019, 3:33 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 12 2019, 3:33 PM
Hadi updated the task description. (Show Details)May 12 2019, 3:39 PM

In the Wikipedia in Lao, subpages of userpages are open to robots of search engines. In other language versions this is not allowed

Please mention a specific other language, or explain what exactly makes you think so.
I do not see any wiki/User in https://en.wikipedia.org/robots.txt , for example.

Search engines should show only WP articles and not user pages or user sub pages.

I do not see a good reason for that.

https://meta.wikimedia.org/wiki/Steward_requests/Miscellaneous#Lao_Wikipedia:_Indexing_by_robots_of_user_pages

That link does not work.

Hadi added a comment.May 13 2019, 2:08 PM

Here as example the infopage of my sandbox in English: https://en.wikipedia.org/w/index.php?title=User:Hadi/sandbox&action=info Here is stated: Indexing by robots = Disallowed

Sorry for the Steward page link, the thread has been archived meanwhile here:
https://meta.wikimedia.org/wiki/Steward_requests/Miscellaneous/2019-05#Lao_Wikipedia:_Indexing_by_robots_of_user_pages

Aklapper renamed this task from Indexing by robots of user pages in Lao Wikipedia to Disable indexing by robots of user pages in Lao Wikipedia.May 13 2019, 2:49 PM
Urbanecm triaged this task as Normal priority.
Urbanecm changed the subtype of this task from "Bug Report" to "Task".
Restricted Application added a project: User-Urbanecm. · View Herald TranscriptMay 25 2019, 12:02 PM

Can you demonstrate community consensus please?

Hadi added a comment.May 26 2019, 4:08 PM

sorry, because I dont speak this language I'm not able to demonstrate community consenus.

In all languages I understand the user pages are not indexed by search engines. Why should this be different in Lao? I think this wasn't made by purpose but by mistake.

In all languages I understand the user pages are not indexed by search engines.

That statement is not correct. See wgNamespaceRobotPolicies in https://noc.wikimedia.org/conf/InitialiseSettings.php.txt

Hadi added a comment.May 26 2019, 4:31 PM

Background why I'm asking to change the indexing by robots:
I taught a new user how to prepare new articles in the personal sandbox and then publish them.
Searching afterwoods with Google showed the sandbox page with her username.
The new user didn't like that at all.
So I fear that she will not continue because of that...

Urbanecm closed this task as Invalid.May 26 2019, 4:42 PM
Urbanecm removed Urbanecm as the assignee of this task.
Urbanecm added a subscriber: Urbanecm.

As @Aklapper pointed out, only projects configured to have user namespace unindexed has noindex policy deployed. Since you considered that a bug, while it is a feature, I'm going to close this task as Invalid. I understand she doesn't like her username being visible at Google, but community consensus is a necessary thing for any configuration changes requested by a community member. You can tell the user she can always turn off indexing by putting __NOINDEX__ at the beggining of her sandbox, as well as any other page.

Hadi added a comment.May 26 2019, 4:54 PM

A person without software knowledge I can not explain what you propose (she uses the Visual Editor).

Can you show me that the Lao community wanted that robots index the user pages? @Aklapper

I regret the end of this my first task on phabricator and I am disappointed.

A person without software knowledge I can not explain what you propose (she uses the Visual Editor).

There's VE way how to do the same. Click the "three lines" icon (next to the questionmark), click Advanced settings, then set "Let this page be indexed by search engines - selecting Yes may prevent saving of the page" to "No".

Can you show me that the Lao community wanted that robots index the user pages? @Aklapper

That's the default behaviour. Community consensus is needed for change, not for keeping the default.

I regret the end of this my first task on phabricator and I am disappointed.

Can you show me that the Lao community wanted that robots index the user pages? @Aklapper

I cannot, because any software needs to have default settings. The default setting is to allow indexing. Communities are welcome to agree on changing default settings. See https://meta.wikimedia.org/wiki/Requesting_wiki_configuration_changes how to do that.