Page MenuHomePhabricator

ErrorException from line 155 of /srv/mediawiki/php-1.34.0-wmf.4/extensions/Wikibase/lib/includes/Formatters/CachingKartographerEmbeddingHandler.php: PHP Notice: Undefined variable: rlModulesArr
Closed, ResolvedPublicPRODUCTION ERROR

Description

Error

Request URL: /w/api.php
Request ID: XNlL4gpAIDUAABDN9i0AAABE

message
ErrorException from line 155 of /srv/mediawiki/php-1.34.0-wmf.4/extensions/Wikibase/lib/includes/Formatters/CachingKartographerEmbeddingHandler.php: PHP Notice: Undefined variable: rlModulesArr
trace
#0 /srv/mediawiki/php-1.34.0-wmf.4/extensions/Wikibase/lib/includes/Formatters/CachingKartographerEmbeddingHandler.php(155): MWExceptionHandler::handleError(integer, string, string, integer, array, array)
#1 /srv/mediawiki/php-1.34.0-wmf.4/extensions/Wikibase/lib/includes/Formatters/CachingKartographerEmbeddingHandler.php(89): Wikibase\Lib\CachingKartographerEmbeddingHandler->getMapframeInitJS(string, array, array)
#2 /srv/mediawiki/php-1.34.0-wmf.4/extensions/Wikibase/lib/includes/Formatters/GlobeCoordinateKartographerFormatter.php(78): Wikibase\Lib\CachingKartographerEmbeddingHandler->getPreviewHtml(DataValues\Geo\Values\GlobeCoordinateValue, LanguageAr)
#3 /srv/mediawiki/php-1.34.0-wmf.4/extensions/Wikibase/lib/includes/Formatters/DispatchingValueFormatter.php(75): Wikibase\Lib\GlobeCoordinateKartographerFormatter->format(DataValues\Geo\Values\GlobeCoordinateValue)
#4 /srv/mediawiki/php-1.34.0-wmf.4/extensions/Wikibase/lib/includes/Formatters/PropertyValueSnakFormatter.php(148): Wikibase\Lib\Formatters\DispatchingValueFormatter->formatValue(DataValues\Geo\Values\GlobeCoordinateValue, string)
#5 /srv/mediawiki/php-1.34.0-wmf.4/extensions/Wikibase/lib/includes/Formatters/PropertyValueSnakFormatter.php(117): Wikibase\Lib\PropertyValueSnakFormatter->formatValue(DataValues\Geo\Values\GlobeCoordinateValue, string)
#6 /srv/mediawiki/php-1.34.0-wmf.4/extensions/Wikibase/lib/includes/Formatters/DispatchingSnakFormatter.php(151): Wikibase\Lib\PropertyValueSnakFormatter->formatSnak(Wikibase\DataModel\Snak\PropertyValueSnak)
#7 /srv/mediawiki/php-1.34.0-wmf.4/extensions/Wikibase/lib/includes/Formatters/ErrorHandlingSnakFormatter.php(68): Wikibase\Lib\DispatchingSnakFormatter->formatSnak(Wikibase\DataModel\Snak\PropertyValueSnak)
#8 /srv/mediawiki/php-1.34.0-wmf.4/extensions/Wikibase/repo/includes/Api/FormatSnakValue.php(115): Wikibase\Lib\Formatters\ErrorHandlingSnakFormatter->formatSnak(Wikibase\DataModel\Snak\PropertyValueSnak)
#9 /srv/mediawiki/php-1.34.0-wmf.4/extensions/Wikibase/repo/includes/Api/FormatSnakValue.php(92): Wikibase\Repo\Api\FormatSnakValue->formatValue(array, DataValues\Geo\Values\GlobeCoordinateValue, NULL)
#10 /srv/mediawiki/php-1.34.0-wmf.4/includes/api/ApiMain.php(1593): Wikibase\Repo\Api\FormatSnakValue->execute()
#11 /srv/mediawiki/php-1.34.0-wmf.4/includes/api/ApiMain.php(531): ApiMain->executeAction()
#12 /srv/mediawiki/php-1.34.0-wmf.4/includes/api/ApiMain.php(502): ApiMain->executeActionWithErrorHandling()
#13 /srv/mediawiki/php-1.34.0-wmf.4/api.php(87): ApiMain->execute()
#14 /srv/mediawiki/w/api.php(3): include(string)

Impact

Notes

Event Timeline

Krinkle created this task.May 13 2019, 10:55 AM
Restricted Application added a project: Wikidata. · View Herald TranscriptMay 13 2019, 10:55 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Seems like something Phan should have caught easily?

Caused by https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/Wikibase/+/506867/.

Change 509791 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/Wikibase@master] Follow-up I1f83348eb: Actually set $rlModulesArr, not over-write $rlModules and use null

https://gerrit.wikimedia.org/r/509791

Change 509791 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Follow-up I1f83348eb: Actually set $rlModulesArr, not over-write $rlModules and use null

https://gerrit.wikimedia.org/r/509791

Change 509801 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/Wikibase@wmf/1.34.0-wmf.4] Follow-up I1f83348eb: Actually set $rlModulesArr, not over-write $rlModules and use null

https://gerrit.wikimedia.org/r/509801

Change 509801 merged by Reedy:
[mediawiki/extensions/Wikibase@wmf/1.34.0-wmf.4] Follow-up I1f83348eb: Actually set $rlModulesArr, not over-write $rlModules and use null

https://gerrit.wikimedia.org/r/509801

Mentioned in SAL (#wikimedia-operations) [2019-05-13T12:08:05Z] <reedy@deploy1001> Synchronized php-1.34.0-wmf.4/extensions/Wikibase/lib/includes/Formatters/CachingKartographerEmbeddingHandler.php: T223085 (duration: 00m 50s)

Krinkle closed this task as Resolved.May 13 2019, 10:16 PM
Krinkle claimed this task.
Krinkle reassigned this task from Krinkle to Jdforrester-WMF.
Krinkle removed a project: Patch-For-Review.
Krinkle added a project: Performance-Team.
mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:07 PM