Page MenuHomePhabricator

Top of #p-personal cropped/cut on zh-wiki using IE (CSS issues)
Closed, DeclinedPublic

Description

Just as the attachment indicates, when using IE, the bullet dot is showing, the top (maybe) 2 px of every character is missing. This happens on both #p-personal and #panel. It seems not to be a local problem because when I access http://en.wikipedia.org/wiki/?useskin=vector&uselang=zh-cn, the same thing happens. Please help fix it, thanks.

My user-agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; Tablet PC 2.0; OfficeLiveConnector.1.4; OfficeLivePatch.1.3; .NET CLR 4.0.20506)

And additionally, those problems don't appear on Firefox.

Best regards.


Version: 1.21.x
Severity: major
OS: Windows 7
Platform: PC

Details

Reference
bz20319

Event Timeline

bzimport raised the priority of this task from to Normal.
bzimport set Reference to bz20319.
bzimport added a subscriber: Unknown Object (MLST).
jimmyxu created this task.Aug 20 2009, 10:04 AM

Created attachment 6478
Showcase

Attached:

Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1), default configuration of IE.

"the bullet dot is showing" yes. bullets are visible.
"the top (maybe) 2 px of every character is missing" no. complete characters can be seen.

Created attachment 6479
#p-personal

(In reply to comment #2)

Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1), default configuration
of IE.

"the bullet dot is showing" yes. bullets are visible.
"the top (maybe) 2 px of every character is missing" no. complete characters
can be seen.

In my virtual machine, user agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
The chars in #panel seems good, but those in #p-personal lost their head, just as the attachment indicates.

attachment Bug 20319 2.png ignored as obsolete

TheDJ added a comment.Mar 15 2010, 3:32 PM

This seems fixed to me and should probably closed (Tested with IE8 and provided link)

I am unable to reproduce using IE6, IE7 or IE8. I'm going to close this now.

hydrogen_cyanide wrote:

(In reply to comment #6)

I am unable to reproduce using IE6, IE7 or IE8. I'm going to close this now.

"The top is not showing" is reproduced again:
http://zh.wikipedia.org/wiki/Wikipedia:%E7%94%A8%E6%88%B6%E9%AB%94%E9%A9%97%E5%8F%8D%E9%A5%8B#.E9.A0.81.E9.9D.A2.E3.80.82

Maybe this is related to font?

  • Bug 24300 has been marked as a duplicate of this bug. ***

sumanah wrote:

Internet Explorer users: are you still experiencing this problem? I am wondering whether it is still happening, now that we have deployed MediaWiki 1.18 to all Wikimedia Foundation wikis. If you are, please provide screenshots and tell us what version of IE you are running and what version of Windows you are running. Thank you.

(In reply to comment #11)

Internet Explorer users: are you still experiencing this problem? I am
wondering whether it is still happening, now that we have deployed MediaWiki
1.18 to all Wikimedia Foundation wikis. If you are, please provide screenshots
and tell us what version of IE you are running and what version of Windows you
are running. Thank you.

I confirm that the bug still exists and the behavior is exactly the same.

TheDJ added a comment.Dec 4 2011, 12:49 PM

I don't have IE, but i suspect this is due lineheight issues that IE is famous for. These elements have:

div#mw-panel div.portal div.body ul li {
line-height: 1.125em;
}

if someone can investigate

If this still happens, could you attach a bigger screenshot? I have problems to find where exactly the problem would be shown...

Created attachment 11194
#p-personal as requested by Andre

Attachment: Upper is the actual #p-personal and lower is what it should look like.

(In reply to comment #14)

If this still happens, could you attach a bigger screenshot? I have problems to
find where exactly the problem would be shown...

#panel LGTM, but #p-personal is still the same as my comment #3 stats.

Attached:

Thanks, this is helpful!

Now wondering where to move this, as "UsabilityInitiative" is not a good place for this report...

TheDJ added a comment.Apr 21 2013, 1:43 PM

Might be interesting to see if https://gerrit.wikimedia.org/r/#/c/55126/ would solve this issue. I don't have IE, so I can't test.

(In reply to comment #17)

Might be interesting to see if https://gerrit.wikimedia.org/r/#/c/55126/
would solve this issue.

Patch got abandoned...

demon removed a subscriber: demon.Aug 19 2015, 4:41 PM
Danny_B moved this task from Unsorted to IE8 on the Browser-Support-Internet-Explorer board.
Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptMay 6 2016, 2:27 PM
Aklapper lowered the priority of this task from Normal to Lowest.May 6 2016, 2:56 PM

Lowest priority as this is about IE8.

Krinkle removed a subscriber: Krinkle.May 10 2016, 4:11 PM

see https://lists.wikimedia.org/pipermail/wikitech-l/2015-November/083964.html

Internet Explorer 8 is being deprecated. Close the task?

Shizhao closed this task as Declined.Feb 14 2019, 7:07 AM
Shizhao moved this task from Backlog to Closed on the Chinese-Sites board.Feb 18 2019, 2:34 AM