Page MenuHomePhabricator

UX improvement for hiding user pages in "What links here"
Closed, DeclinedPublic

Description

In "What links here" pages, there are three filters:
Hide transclusions | Hide links | Hide redirects

When one looks for backward links, one usually does not care about user pages, one care about Wikipedia concepts. Example: https://en.wikipedia.org/wiki/Special:WhatLinksHere/Hacker_ethic

To "Hide User Pages", one can use a namespace (see below) but this feature is not visible on screen.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 16 2019, 4:58 PM

There is already a namespace filter with invert option to reach this. Having a option doing the same sounds wrong.

Thanks. What is a namespace filter?

DannyS712 closed this task as Declined.May 16 2019, 8:10 PM
DannyS712 claimed this task.
DannyS712 added a subscriber: DannyS712.

@martin.monperrus It allows you to exclude or only included based on the namespace of the page.
Example:

Hope this helps.

I confirm that the namespace feature is a solution. It means it's not a missing feature but a UI/UX problem. I'm renaming this ticket.

martin.monperrus renamed this task from add "Hide user pages" as filter for "What links here" to UX improvement for hiding user pages in "What links here".May 17 2019, 4:42 AM
martin.monperrus updated the task description. (Show Details)

The problem is that the feature is hidden behind a dropdown button.

What about adding shortcuts for the most common namespaces, visible on screen: "only articles", "only files", "only books"

For other users maybe other namespaces are more important than your list, so the existing implementation of the feature is open for all namespaces and can be used from all peoples.

Maybe the concept of namespaces is not clear, so the idea of using the namespace filter was not given for the first question.

I would avoid adding "common" variants as default to the UI, because each wiki has it own and suggest to not change mediawiki here (Status: Declined or Invalid)

I suggest to modifiy the UI with javascript to match your needs here, but for doing that you have to ask on wiki - https://en.wikipedia.org/wiki/Wikipedia:User_scripts