Page MenuHomePhabricator

external ID linking issue on Factgrid
Closed, ResolvedPublic

Description

Problem:
External identifiers are not properly linked on Factgrid even though the formatter URL seems to be properly defined on the Property.
Assumption: The config isn't properly set up to recognize the formatter URL Property.

Example:
GND ID on https://database.factgrid.de/wiki/Item:Q133

Acceptance criteria:

  • Identifiers are linked if the formatter URL is defined on the respective Property

Event Timeline

We will check:

  • how to configure which property to use for formatting URLs
  • whether a correct documentation exist
  • update this task with a comment pointing factgrid where to look to check/configure properly

@alaa_wmde - I confess my limited technical understanding. If there are things we need to reconfigure - let me know (and I will try to find someone who can reconfigure a wikibase installation...)

Addshore renamed this task from external ID linking issue on Facgrid to external ID linking issue on Factgrid.Jun 27 2019, 12:08 AM

@Olaf_Simons as a next step the developers are going to improve the documentation and then report back here once that's done.

hoo added a subscriber: hoo.Jul 11 2019, 9:06 PM

Please try to follow these steps: T226499#5326479

@Olaf_Simons Hello, We have tried this on our side and in several places and we still couldn't reproduce the issue. Please make sure you run the maintenance script. Is there anyone who can run this? @Lucas_Werkmeister_WMDE maybe?

@Ladsgroup I'm in Edinburgh for the rest of the week (conference marathon https://www.bsecs.org.uk/isecs/en/programme/)

Can we talk about this - on the phone perhaps, later next week?

Deeply grateful for your help,
Olaf

Dr. Olaf Simons
Gotha Research Centre at the University of Erfurt
Schloss Friedenstein, Pagenhaus
99867 Gotha

olaf.simons@pierre-marteau.com
Office: +49-361-737-1722
Mobile: +49-179-5196880

Privat: Hauptmarkt 17b/ 99867 Gotha

Ladsgroup <no-reply@phabricator.wikimedia.org> hat am 16. Juli 2019 um 10:15 geschrieben:
Ladsgroup added a comment.

@Olaf_Simons Hello, We have tried this on our side and in several places and we still couldn't reproduce the issue. Please make sure you run the maintenance script. Is there anyone who can run this? @Lucas_Werkmeister_WMDE maybe?

TASK DETAIL

https://phabricator.wikimedia.org/T223552

EMAIL PREFERENCES

https://phabricator.wikimedia.org/settings/panel/emailpreferences/

To: Ladsgroup
Cc: Ladsgroup, hoo, alaa_wmde, Olaf_Simons, Lucas_Werkmeister_WMDE, Lydia_Pintscher, darthmon_wmde, Nandana, Lahi, Gq86, GoranSMilovanovic, QZanden, LawExplorer, _jensen, rosalieper, Jonas, Wikidata-bugs, aude, Mbch331

@Ladsgroup I'm in Edinburgh for the rest of the week (conference marathon https://www.bsecs.org.uk/isecs/en/programme/)
Can we talk about this - on the phone perhaps, later next week?

Send me an email when you're back

@Olaf_Simons is this still an issue on your side, or have you managed to fix it?

Yes this is still an issue and I regret, I am not the person with the technical knowledge to fix this. If someone could guide me through the steps that would be cool. I'd just be as grateful for a telephone chat to get a better understanding of the problem. (+49-361-737-1722 my office phone usually between 9:00 and 18:00 CET or +49-179-5196880 on mobile)

Addshore changed the task status from Open to Stalled.Nov 5 2019, 1:54 PM
Addshore removed a project: Wikidata-Campsite.
Addshore added a subscriber: Addshore.

Stalled so removing from the campsite.
This should just be a configuration fix on factgrid that is needed?

Lydia_Pintscher changed the task status from Stalled to Open.Nov 5 2019, 9:03 PM

Yes and we should help :)

@Olaf_Simons if you could provide us with your wikibase configuration, then we can probably help some more.

Addshore triaged this task as Medium priority.Nov 6 2019, 10:36 AM
Addshore moved this task from incoming to monitoring on the Wikidata board.

I don't think that says anything about the external ID config.

Is it configured at all?

What is $wgWBRepoSettings['formatterUrlProperty'] set to?

and suddenly it works - whatever you guys did - thanks from the FactGrid editors.

Addshore closed this task as Resolved.Fri, Nov 15, 2:22 PM
Addshore claimed this task.
Restricted Application added a project: User-Addshore. · View Herald TranscriptFri, Nov 15, 2:22 PM