Page MenuHomePhabricator

Navigation issue on campaign home page
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:
I am on one campaign home page
I am not logged in
I click on get started

Actual Results:
It leads me to campaign directory

Expected Results:
I should go to campaign edit/input page

Event Timeline

Anthere created this task.May 17 2019, 12:00 PM
Eugene233 moved this task from Backlog to Incoming Bugs on the ISA board.May 21 2019, 8:27 PM

@Anthere I am sure it should be because a user needs to login to participate in the campaign. For the simple reason that if they don't login they might participate and their contributions will not be tracked.

Yet, we said very clearly that non logged-in people should be able to see that page. I remember we said that if the person was not logged-in and provided some input (such as new depicts), when she would click on save, she would be asked to log-in. And obviously, if not logged-in, it would not save their contribution

Change 512163 had a related patch set uploaded (by Eugene233; owner: Eugene233):
[labs/tools/Isa@master] Navigation issue on campaign home page

https://gerrit.wikimedia.org/r/512163

Eugene233 moved this task from Incoming Bugs to In progress on the ISA board.

Change 512163 merged by jenkins-bot:
[labs/tools/Isa@master] Navigation issue on campaign home page

https://gerrit.wikimedia.org/r/512163

Anthere closed this task as Resolved.May 24 2019, 10:45 AM

checked. Good