Page MenuHomePhabricator

Interwiki search use canonical namespace name
Closed, ResolvedPublic

Description

An interwiki search which return results on another project which are not in the main namespace, use the canonical namespace, which is wrong for that language. So in the URL it should have 'Ayuda' instead of 'Help'.
Note that since groups are joined by language, it could use the local translation for that namespace, except for NS_PROJECT (NS_PROJECT_TALK). The value of wgMetaNamespace would need to be fetched from SiteConf.

Results from extra namespaces don't present this issue, they have the right namespace name.

Related to bug 15452 ?


Version: master
Severity: normal
URL: http://en.wikipedia.beta.wmflabs.org/wiki/Special:Search?search=C%C3%B3mo%20se%20edita%20una%20p%C3%A1gina&fulltext=Buscar&ns0=1&ns1=1&ns2=1&ns3=1&ns4=1&ns5=1&ns6=1&ns7=1&ns8=1&ns9=1&ns10=1&ns11=1&ns12=1&ns13=1&ns14=1&ns15=1&ns102=1&ns103=1&redirs=0

Details

Reference
bz20375

Event Timeline

bzimport raised the priority of this task from to High.Nov 21 2014, 10:58 PM
bzimport added a project: CirrusSearch.
bzimport set Reference to bz20375.

(In reply to comment #0)

An interwiki search which return results on another project [...]

Platonides, I don't remember, wasn't this feature removed completely? (And is there a bug somewhere to restore it? It's one of the features I liked most in MediaWiki's history.)

Yes, it was removed at some point. Although this bug shows that it was active in 2009. Feel free to open a bug to restore it, blocking on this bug.

  • Bug 21717 has been marked as a duplicate of this bug. ***

See attachment 6850.

Interwiki search no longer exists in Lucene, and interwiki search in Cirrus will look nothing like it looks in Lucene. Therefore, in the present day, this bug is RESOLVED INVALID.

Actually, the very example provided in comment 0 proves this bug is valid for Cirrus too (though I wouldn't call it a severe bug).

That link certainly doesn't spit out a nice looking page:
en.wikivoyage.org results:

wikivoyage:Project:LanguageEs.php

Yikes!

This one doesn't look great either:
http://en.wikipedia.beta.wmflabs.org/w/index.php?title=Special%3ASearch&profile=advanced&search=main&fulltext=Search&ns0=1&ns1=1&ns2=1&ns3=1&ns4=1&ns5=1&ns6=1&ns7=1&ns8=1&ns9=1&ns10=1&ns11=1&ns12=1&ns13=1&ns14=1&ns15=1&profile=advanced
en.wikivoyage.org results:

wikivoyage:Main Page
wikivoyage:Talk:Main Page
wikivoyage:User talk:Peterfitzgerald
wikivoyage:Project:Main Page guidelines

(more)
en.wikinews.org results:

wikinews:Main Page

(more)
en.wikivoyage.org results:

wikivoyage:Disneyland
wikivoyage:Kruger National Park
wikivoyage:Indonesia
wikivoyage:Moscow

These are all ugly, but don't show the language problem. I can't reproduce the language issue but wouldn't be surprised about it. Say you search on de.wikipedia.org. You want the namespaces to come back translated properly into German regardless of what the actual wiki's language is in.

demon added a comment.Feb 13 2014, 4:34 AM

This is sort of being worked on as a result of other things.

demon added a comment.Mar 13 2014, 8:11 PM

I think this is better as of today. We should configure it on beta for more languages and test.

demon added a comment.Jun 3 2014, 9:49 PM

I'm pretty sure this is better now. If we can find any examples in Cirrus where it's wrong feel free to reopen.