Page MenuHomePhabricator

Hide Cologne Blue skin in preferences
Closed, ResolvedPublic

Description

In T147696 (run in 2016) we saw that cologne blue had 45 very active editors, 324 active users and 2 544 editors with at least one edit.

For nonactive users there is no indication that this skin is badly supported (see T178422) and adoption is not encouraged.

See https://lists.wikimedia.org/pipermail/wikitech-l/2014-March/075101.html

We have discussed deprecating this skin for many years but we have done nothing about it. In the meantime we cause embarrassment to ourselves by irresponsibly presenting it as an option despite the fact we barely maintain it and there are many obvious visual bugs. At the same time we invest time making things work to avoid seeing fatals in production at the cost of slower development in the skins we do maintain.

As an experiment we will see how hiding cologne blue in preferences impacts usage and can in future use this as an interim step to deprecate skins if deemed necessary.

Practically we will add cologneblue to wgSkipSkins.

This will allow users to continue to use this skin but will hide the skin option for those that have not opted into the experience. For users who opt out of the skin and then want to opt back in we hope we can use this to start a narrative about the cost of such support. These users will also be able to opt back in by adding useskin=cologneblue in the url of the preferences page

We can of course at any time reverse this decision. It's a config flag but hopefully we can at least identify people that need this skin and work with them to realise their needs in other more sustainable ways.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 19 2019, 1:27 PM

Change 511321 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[operations/mediawiki-config@master] Update wgSkipSkins to experiment with not showing skins to users

https://gerrit.wikimedia.org/r/511321

Does this need changes in MediaWiki? If not, it should be in the Wikimedia-Site-requests project.

Legoktm renamed this task from Hide skin from preferences to Hide Cologne Blue skin in preferences .May 20 2019, 12:15 AM
Legoktm added a project: CologneBlue.

A small code change was made via https://gerrit.wikimedia.org/r/511071. It does not have any effect as long as the config change in https://gerrit.wikimedia.org/r/511321 is not merged.

When is the deployment?

Possible phrasing: "Due to the absence of maintenance of Cologne Blue skin, the link to activate it will be hidden."
And potentially adding "Users using it are invited to switch to an other skin."

I'm happy to assist the deployment of this config change, but there is currently no fixed plan. I might try to schedule it for next week.

The suggested text for an announcement sounds great!

Aklapper added a subscriber: matmarex.

CC'ing @matmarex as per https://phabricator.wikimedia.org/T115430#1724957 .
Also wondering if someone ("we") could gather updated Cologne Blue user stats?

I am still volunteering to maintain the skin. Please file tasks if there are bugs. :)

I don't think $wgSkipSkins works the way you expect. Adding a skin there makes it entirely unusable, not just hides it from preferences. Users who has the skin set in preferences will instead see the wiki default skin, and their skin setting will be reset when they change any other preference. I think the skin is not even accessible via useskin. (If you write some code to actually hide skins from preferences without disabling them completely, please make sure that the user's skin setting is not lost when they change unrelated preferences.)

$wgSkipSkins never blocked skins from being used. What it does is really just hiding these skins from [[Special:Preferences]], nothing else.

It was always possible to use …?useskin=apioutput and useskin=fallback. It is also possible to use the API to set any hidden skin in your user preferences including the technical ones, if you really want to.

The patch https://gerrit.wikimedia.org/r/511071 changed the behavior very slightly. With this patch in place, the non-technical skins listed in $wgSkipSkins will still show up in [[Special:Preferences]] as long as a user does have this skin activated, or requested it via useskin. The behavior for the technical skins "apioutput" and "fallback" did not changed.

We made sure the users setting get not lost just by using setting other, unrelated preferences. That was the whole reason for the mentioned patch.

Huh, indeed. I'm surprised but glad to have been wrong!

Johan added a subscriber: Johan.May 23 2019, 8:09 PM

@thiemowmde Please let us know (for Tech News purposes) when the deployment has been scheduled. (:

Johan added a comment.May 23 2019, 8:10 PM

If we're doing this.

@thiemowmde did the SWAT happen?

Change 526530 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/core@master] Correct wgSkipSkins key check

https://gerrit.wikimedia.org/r/526530

Change 526530 merged by jenkins-bot:
[mediawiki/core@master] preferences: Fix skinname msg check in generateSkinOptions

https://gerrit.wikimedia.org/r/526530

@Jdlrobson, are we doing this?

There was a bug in the code. Earliest we could do this is 8/8 but earliest I can do this is 8/12.

@thiemowmde are you able to do 8/8 or would you like me to do this?

Since it is an upcoming change, it worth to be announced in Tech News.

@Jdlrobson is the description on T223824#5197306 still valid?

Yup. Description still valid.

I've added it to Tech News with this wording (link). Please tweak that within the next 24 hours, if needed, before the issue is frozen for translation. Thanks. https://meta.wikimedia.org/w/index.php?title=Tech/News/2019/33&diff=19274057&oldid=19273741&diffmode=source

Sounds good! I will likely SWAT this Monday/Tuesday next week.

@Jdlrobson What about the deployment? “Monday next week” is today, and I see not even a line about it on wikitech:Deployments.

@Jdlrobson What about the deployment? “Monday next week” is today, and I see not even a line about it on wikitech:Deployments.

Tomorrow. https://phabricator.wikimedia.org/T223824#5403628

There doesn't seem to be anyone around who can SWAT so this will now probably have to wait until post-wikimania.

PlavorSeol added a subscriber: PlavorSeol.EditedWed, Aug 14, 2:44 AM

Wow, do you seriously check valid skins just by skinname-$currentUserSkin message?
WOW, JUST WOW.
Not all skins have skinname-$skinname message nor they are required to have it.

Yeah, I know all skins used on Wikimedia have it, so just checking it is enough. Cool, we're done. We don't care about any third-party. It's COOL. IT'S VERY COOL, RIGHT?
Did the developers decide to drop third-party support for MediaWiki?

@PlavorSeol There are many many thousands of things that someone might not know (or might not remember at any given time, or might not be able to find the documentation for). Please try to phrase your concerns with good faith in mind. This was an unnecessarily aggressive way to state your concerns and reminder. Mistakes happen, we're all just humans.

Abstain - per users option.

@Znotch190711: Phabricator tasks are not places for voting. :)

@PlavorSeol: You have been asked before to please respect the etiquette.
If this is not possible then I kindly request that you spend your time in different venues than Wikimedia Phabricator. Thanks for your understanding.

Fito awarded a token.Wed, Aug 14, 10:34 PM

Change 511321 merged by jenkins-bot:
[operations/mediawiki-config@master] Update wgSkipSkins to experiment with not showing skins to users

https://gerrit.wikimedia.org/r/511321

Mentioned in SAL (#wikimedia-operations) [2019-08-20T23:10:34Z] <urbanecm@deploy1001> Synchronized wmf-config/InitialiseSettings.php: SWAT: b94b647: Update wgSkipSkins to experiment with not showing skins to users (T223824) (duration: 00m 58s)

Jdlrobson closed this task as Resolved.Wed, Aug 21, 4:55 PM
Jdlrobson claimed this task.