When running phan 1.3.4 from phan-config 0.6.0 in the wmf CI it shows a warning:
future major version of Phan will require PHP 7.1+ to run, but PHP 7.0.33-0+deb9u2 is installed. PHP 7.0 reached its end of life in December 2018. (Set PHAN_SUPPRESS_PHP_UPGRADE_NOTICE=1 to suppress this message)
On my local machine I was getting a message that php-ast 1.0.1 will be needed by newer phan.
At the moment phan 2.0.0 release candidat are there which needs php7.1
Please prepare the docker to run on newer php or apply a feature switch to run the stable phan 2.0.0 when released.