Page MenuHomePhabricator

[Collections] RuntimeException from line 109 of /srv/mediawiki/php-1.34.0-wmf.6/includes/TemplateParser.php: Could not locate template: /srv/mediawiki/php-1.34.0-wmf.6/extensions/Collection/includes/templates/create-book.mustache
Closed, ResolvedPublic

Description

Error

Request URL: https://www.mediawiki.org/wiki/User_hub
Request ID: XOQSMgpAMFoAAB3YYqwAAABA

message
RuntimeException from line 109 of /srv/mediawiki/php-1.34.0-wmf.6/includes/TemplateParser.php: Could not locate template: /srv/mediawiki/php-1.34.0-wmf.6/extensions/Collection/includes/templates/create-book.mustache
trace
#0 /srv/mediawiki/php-1.34.0-wmf.6/includes/TemplateParser.php(222): TemplateParser->getTemplate(string)
#1 /srv/mediawiki/php-1.34.0-wmf.6/extensions/Collection/includes/CollectionHooks.php(265): TemplateParser->processTemplate(string, array)
#2 /srv/mediawiki/php-1.34.0-wmf.6/extensions/Collection/includes/CollectionHooks.php(223): CollectionHooks::renderBookCreatorBox(Title)
#3 /srv/mediawiki/php-1.34.0-wmf.6/includes/Hooks.php(174): CollectionHooks::siteNoticeAfter(string, SkinVector)
#4 /srv/mediawiki/php-1.34.0-wmf.6/includes/Hooks.php(202): Hooks::callHook(string, array, array, NULL)
#5 /srv/mediawiki/php-1.34.0-wmf.6/includes/skins/Skin.php(1607): Hooks::run(string, array)
#6 /srv/mediawiki/php-1.34.0-wmf.6/includes/skins/SkinTemplate.php(449): Skin->getSiteNotice()
#7 /srv/mediawiki/php-1.34.0-wmf.6/includes/skins/SkinTemplate.php(228): SkinTemplate->prepareQuickTemplate()
#8 /srv/mediawiki/php-1.34.0-wmf.6/includes/OutputPage.php(2749): SkinTemplate->outputPage()
#9 /srv/mediawiki/php-1.34.0-wmf.6/includes/MediaWiki.php(872): OutputPage->output(boolean)
#10 /srv/mediawiki/php-1.34.0-wmf.6/includes/MediaWiki.php(884): Closure$MediaWiki::main()
#11 /srv/mediawiki/php-1.34.0-wmf.6/includes/MediaWiki.php(515): MediaWiki->main()
#12 /srv/mediawiki/php-1.34.0-wmf.6/index.php(42): MediaWiki->run()
#13 /srv/mediawiki/w/index.php(3): include(string)
#14 {main}

Impact

No clue, but some pages on https://www.mediawiki.org/ emit the error.

Notes

Event Timeline

hashar created this task.May 21 2019, 3:02 PM
Restricted Application added subscribers: Liuxinyu970226, Aklapper. · View Herald TranscriptMay 21 2019, 3:02 PM
hashar triaged this task as Unbreak Now! priority.May 21 2019, 3:02 PM

Caused by files being moved around in 3299642a484aac96c787aad809116d3dc8bab545 . The templates are in /templates/ and are no more found:

CollectionHooks.php got moved to includes/CollectionHooks.php but:

public static function renderBookCreatorBox( Title $title, $mode = '' ) {
    global $wgOut, $wgExtensionAssetsPath, $wgRequest;
    $templateParser = new TemplateParser( __DIR__ . '/templates' );
hashar lowered the priority of this task from Unbreak Now! to High.May 21 2019, 3:12 PM

That was just a spike of 50 errors. so hardly preventing train from progressing imho.

Daimona claimed this task.May 21 2019, 3:17 PM
Daimona added a subscriber: Daimona.

Gonna fix it anyway shortly.

Change 511733 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/extensions/Collection@master] Fix path to templates

https://gerrit.wikimedia.org/r/511733

Daimona reassigned this task from Daimona to Reedy.May 21 2019, 3:23 PM

Faster gun draw.

Change 511733 merged by jenkins-bot:
[mediawiki/extensions/Collection@master] Fix paths broken by moving files

https://gerrit.wikimedia.org/r/511733

Change 511755 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/extensions/Collection@wmf/1.34.0-wmf.6] Fix paths broken by moving files

https://gerrit.wikimedia.org/r/511755

Change 511755 merged by jenkins-bot:
[mediawiki/extensions/Collection@wmf/1.34.0-wmf.6] Fix paths broken by moving files

https://gerrit.wikimedia.org/r/511755

Reedy closed this task as Resolved.May 21 2019, 5:30 PM
Reedy removed a project: Patch-For-Review.

Thank you Sam !

mmodell changed the subtype of this task from "Task" to "Production Error".Wed, Aug 28, 11:07 PM