Page MenuHomePhabricator

wmerrors has no license information
Closed, ResolvedPublic0 Story Points

Description

The main contributors to wmerrors are @tstarling, @Catrope, @Platonides and now @MaxSem (ignoring contributors to debian/ which I (Legoktm) am redoing entirely, and translations/tweaks to errors.html).

It would be good if we could use Apache-2.0 like we did for excimer.

Event Timeline

Legoktm created this task.May 22 2019, 3:45 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 22 2019, 3:45 AM

I'm good with Apache or MIT.

I'm good with Apache or MIT.

Same.

I think MIT is more compatible with upstream. It's what we used for LuaSandbox.

Change 516972 had a related patch set uploaded (by Jforrester; owner: Tim Starling):
[mediawiki/php/wmerrors@master] MIT license

https://gerrit.wikimedia.org/r/516972

I'm also ok with that.

Change 516972 merged by jenkins-bot:
[mediawiki/php/wmerrors@master] MIT license

https://gerrit.wikimedia.org/r/516972

Legoktm closed this task as Resolved.Jun 14 2019, 2:53 AM
Legoktm assigned this task to tstarling.

Thanks everyone.