Page MenuHomePhabricator

[Collections] Fatal error: Call to undefined function wfAjaxCollectionGetItemList()
Closed, ResolvedPublic

Description

Error

Request URL: https://www.mediawiki.org/wiki/MediaWiki
Request ID: XORrJwpAIEIAAH-lkN8AAAAT

message
PHP Fatal Error: Call to undefined function wfAjaxCollectionGetItemList()
trace
 #0 /srv/mediawiki/php-1.34.0-wmf.6/extensions/Collection/includes/CollectionAjaxFunctions.php(52): NO_FUNCTION_GIVEN()
#1 /srv/mediawiki/php-1.34.0-wmf.6/includes/AjaxDispatcher.php(132): CollectionAjaxFunctions::onAjaxCollectionAddArticle(string, string, string)
#2 /srv/mediawiki/php-1.34.0-wmf.6/includes/MediaWiki.php(774): AjaxDispatcher->performAction(User)
#3 /srv/mediawiki/php-1.34.0-wmf.6/includes/MediaWiki.php(515): MediaWiki->main()
#4 /srv/mediawiki/php-1.34.0-wmf.6/index.php(42): MediaWiki->run()
#5 /srv/mediawiki/w/index.php(3): include(string)
#6 {main}

Impact

Notes

Apparently only one occurrence on May 21st 21:10, but the code is definitely broken since the function has been simply removed without updating callers.

Caused by 5065ce08dcbf543c0881a4d42bc21c5ac10cd330

Event Timeline

hashar created this task.May 22 2019, 9:11 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 22 2019, 9:11 AM

Change 512120 had a related patch set uploaded (by Hashar; owner: Hashar):
[mediawiki/extensions/Collection@master] Also rename wfAjaxCollectionGetItemList

https://gerrit.wikimedia.org/r/512120

Change 512122 had a related patch set uploaded (by Hashar; owner: Hashar):
[mediawiki/extensions/Collection@wmf/1.34.0-wmf.6] Also rename wfAjaxCollectionGetItemList

https://gerrit.wikimedia.org/r/512122

Collection seems to be the only extension with callers to this function, according to MediaWiki code search.

Yes that is an internal function that uses to be in /Collections.php has a global function. https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/Collection/+/332929/ moved it to a class static method.

Thank you!

Change 512122 merged by jenkins-bot:
[mediawiki/extensions/Collection@wmf/1.34.0-wmf.6] Also rename wfAjaxCollectionGetItemList

https://gerrit.wikimedia.org/r/512122

Mentioned in SAL (#wikimedia-operations) [2019-05-23T09:51:45Z] <hashar@deploy1001> Synchronized php-1.34.0-wmf.6/extensions/Collection: Rename wfAjaxCollectionGetItemList() T224093 (duration: 00m 57s)

Change 512120 merged by jenkins-bot:
[mediawiki/extensions/Collection@master] Also rename wfAjaxCollectionGetItemList

https://gerrit.wikimedia.org/r/512120

hashar closed this task as Resolved.May 23 2019, 9:52 AM
hashar claimed this task.