Page MenuHomePhabricator

Suggested statements WITH values in UploadWizard configurable via json
Closed, ResolvedPublic

Description

Campaigns are configurable via json like this

https://commons.wikimedia.org/w/index.php?title=Campaign:wlm-es&action=edit

Acceptance criteria:

  • user can enter property ids with one or more item id values into campaign json config, and the metadata step in UW will show an editable panel for each property id from the config with values corresponding the the item ids from the config ... and when a user clicks 'Publish' the structured data on the page will be saved

Details

Related Gerrit Patches:
mediawiki/extensions/UploadWizard : masterValues for suggested statements in UploadWizard for campaigns

Event Timeline

Cparle created this task.May 22 2019, 4:56 PM
Restricted Application added a project: Multimedia. · View Herald TranscriptAug 10 2019, 11:54 PM

Change 530400 had a related patch set uploaded (by Cparle; owner: Cparle):
[mediawiki/extensions/UploadWizard@master] Values for suggested statements in UploadWizard for campaigns

https://gerrit.wikimedia.org/r/530400

Cparle renamed this task from Suggested statements WITH values in UploadWizard configurable via json and query string to Suggested statements WITH values in UploadWizard configurable via json.Aug 15 2019, 3:54 PM
Cparle edited projects, added Structured-Data-Team-Current-Work; removed Multimedia.
Cparle updated the task description. (Show Details)
Cparle removed a project: Epic.Aug 15 2019, 4:00 PM
Cparle moved this task from To Do to Code Review on the Structured-Data-Team-Current-Work board.

Here's an example campaign set up to have P276 (wikidata property 'location') set up as a suggested statement on the metadata page of UW with the value Q1761 (wikidata item 'Dublin'):

{
    "enabled": true,
    "wikibase": {
        "enabled": true,
        "statements": true
    },
    "defaults": {
        "statements": [
            {
                "propertyId": "P276",
                "dataType": "wikibase-entityid",
                "values": [ "Q1761" ]
            }
        ]
    }
}

Change 530400 merged by jenkins-bot:
[mediawiki/extensions/UploadWizard@master] Values for suggested statements in UploadWizard for campaigns

https://gerrit.wikimedia.org/r/530400

Ramsey-WMF moved this task from To Do to Doing on the Structured-Data-Backlog (Current Work) board.
Ramsey-WMF added a subscriber: Ramsey-WMF.

Currently testing this out on Beta, but there's an error. Eric believes the issue is already fixed in another patch that needs review.

Cparle added a comment.EditedSep 5 2019, 2:09 PM

Works for me on beta, except for this bug

Can we close?

Ramsey-WMF closed this task as Resolved.Sep 5 2019, 4:44 PM
Ramsey-WMF claimed this task.

Works on prod too. Can close it.