Page MenuHomePhabricator

Migrate Wikilabels to new DB server
Closed, ResolvedPublic

Description

They need us to move to a new DB server again. Replication is already handled, so all we need to do is to have a bit of downtime while we make the switch.

  • Deploy a config change announcing the maintenance
  • Do the maintenance.

Event Timeline

Halfak created this task.Wed, May 22, 6:02 PM
Bstorm added a comment.EditedWed, May 22, 6:03 PM

Ideally, there should be no config change needed if you are using the wikilabels.db.svc.eqiad.wmflabs address now--unless you mean just for announcing things :)

Yup. We've got that in the config. At the very least, we'll need to do a restart to reconnect to the new DB based on the DNS change. But we'll also probably want a little downtime for when we are in read-only mode.

Would 1800 UTC on Friday, May 24th work for you, @Bstorm?

Bstorm added a comment.EditedWed, May 22, 6:12 PM

Yup! I'm trying other avenues to keep toolsdb from running out of space on the replica as well. If it goes nuclear for some reason before then, I'll try to reach you before doing an emergency switch--and the issue is on the replica not the primary so I can always rebuild if I have to.

The disk I'm worried about went up 2% in a day and is at 88% now. That should get it all done in time, and then the fate of wikilabels will no longer be tied to toolsdb for historical reasons. I'll be able to set it up with a replica of its own as well!

Halfak updated the task description. (Show Details)
Halfak closed this task as Resolved.Tue, Jun 18, 1:39 PM