Page MenuHomePhabricator

UploadStashFileException when uploading image in Visual Editor
Closed, ResolvedPublic

Description

Hello,
after update to MW 1.32.1 from 1.31 (Windows Server 2008 R2, PHP 7.1.14, MariaDB 5.5.5-10.3.14) it is not possible to upload image through interface of Visual Editor. The dialog returns a strange error after click "Upload".

Could not store upload in the stash (UploadStashFileException): "Could not store file "D:\Wiki\Dev/App_Data/temp/chunkedupload_cb59cde85454" at "mwstore://local-backend/local-temp/2/29/20190520131613!chunkedupload_cb59cde85454.".".

However, it is possible to upload file through Special:Upload page.

Any idea if it is a bug or anything else ?

Thank you

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 24 2019, 10:16 AM

Sounds like a configuration issue with your local wiki, maybe a permissions issue?

I did some research and the cause seems to be that temporary folder of PHP on Windows did not have proper permissions.

To resolve it. I set up "upload_tmp_dir" variable in PHP.ini to specific folder and added "Everyone" with read/write permission. Restarted IIS and it looks ok now.

You may close the task.

Esanders closed this task as Resolved.May 27 2019, 10:38 AM
Esanders claimed this task.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptMay 27 2019, 10:38 AM