Page MenuHomePhabricator

Clean up ruby test infrastructure
Closed, ResolvedPublic

Description

All tests have been ported, but some cleanup work is left.

acceptance criteria

  • remove ruby browser tests directory
  • remove Lexeme ruby browser test daily job
  • double check that WikibaseLexeme-related documentation for ruby browser tests is removed
  • check whether rubcop, Gem and Rakefiles are still needed and if not, then remove them
  • double check for other ruby artifacts

Event Timeline

Michael changed the task status from Open to Stalled.May 24 2019, 4:17 PM
Michael created this task.

Stalled on form tests being merged, but this should be the case soon.

Change 514494 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[mediawiki/extensions/Wikibase@master] Drop ruby browser test artifacts

https://gerrit.wikimedia.org/r/514494

Change 514497 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[mediawiki/extensions/WikibaseLexeme@master] Drop ruby browser test artifacts

https://gerrit.wikimedia.org/r/514497

Change 514498 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[integration/config@master] Drop daily ruby browser tests for wikibase and wikibase lexeme

https://gerrit.wikimedia.org/r/514498

Restricted Application added a project: User-Ladsgroup. · View Herald TranscriptJun 5 2019, 2:55 PM

Change 514498 merged by jenkins-bot:
[integration/config@master] Drop daily ruby browser tests for wikibase and wikibase lexeme

https://gerrit.wikimedia.org/r/514498

Change 514507 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[integration/config@master] Drop ruby browser tests from Wikibase

https://gerrit.wikimedia.org/r/514507

Change 514507 merged by jenkins-bot:
[integration/config@master] Drop ruby browser tests from Wikibase and WikibaseLexeme

https://gerrit.wikimedia.org/r/514507

Change 514547 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[integration/config@master] Fix up for I8c55532bad85cff953436b5f5ed6137a61ea142c

https://gerrit.wikimedia.org/r/514547

Change 514547 merged by jenkins-bot:
[integration/config@master] zuul: [Wikibase] Don't run mwselenium-quibble-docker for now

https://gerrit.wikimedia.org/r/514547

Change 514665 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[integration/config@master] zuul: Drop mwselenium from WikibaseLexeme

https://gerrit.wikimedia.org/r/514665

Change 514665 merged by jenkins-bot:
[integration/config@master] zuul: Drop mwselenium from WikibaseLexeme

https://gerrit.wikimedia.org/r/514665

Change 514494 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Drop ruby browser test artifacts

https://gerrit.wikimedia.org/r/514494

Change 514733 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[integration/config@master] zuul: Bring back Wikibase ruby tests

https://gerrit.wikimedia.org/r/514733

Change 514733 merged by jenkins-bot:
[integration/config@master] zuul: Bring back Wikibase ruby tests

https://gerrit.wikimedia.org/r/514733

Mentioned in SAL (#wikimedia-releng) [2019-06-06T15:12:23Z] <hashar> reloading Zuul for I8d6ea5b5491fe50d7144926ef8bc69d4704d4fab T224301

Change 514497 merged by jenkins-bot:
[mediawiki/extensions/WikibaseLexeme@master] Drop ruby browser test artifacts

https://gerrit.wikimedia.org/r/514497

Change 517068 had a related patch set uploaded (by Hashar; owner: Hashar):
[integration/config@master] jjb: remove selenium-{project}-chrome

https://gerrit.wikimedia.org/r/517068

Change 517068 merged by jenkins-bot:
[integration/config@master] jjb: remove selenium-{project}-chrome

https://gerrit.wikimedia.org/r/517068

Addshore moved this task from incoming to in progress on the Wikidata board.Fri, Jun 21, 11:25 PM

So we've removed the daily Wikibase ruby job, although we're far from having migrated all ruby test to node.

Removing WikibaseLexeme daily job was great, but having done that for Wikibase is something which might not necessarily been intended.
@alaa_wmde @Addshore I would like to double check with you that this have been an intended change.

It was my mistake, I will bring it back

Thanks for explanation. I was just not sure if this was intended or not, as I do remember that the removal of ruby Wikibase stuff has already been claimed premature earlier. Having those jobs restored would be cool, but if it waits a few days that'd be cool.
For clarity, once resolved, we should probably close this task ,as it seems to bring more confusion than value.

Lydia_Pintscher closed this task as Resolved.Mon, Jul 15, 11:09 AM