Page MenuHomePhabricator

[regression] Editor is read-only after recovering autosaved changes or switching VE to NWE
Closed, ResolvedPublic

Description

Editor is read-only after recovering autosaved changes.

Event Timeline

matmarex created this task.May 24 2019, 9:08 PM
Restricted Application added a project: VisualEditor. · View Herald TranscriptMay 24 2019, 9:08 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Also, when switching from VE to NWE, it is also read-only.

Change 512438 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/VisualEditor@master] Store 'canEdit' property when auto-saving or switching editors

https://gerrit.wikimedia.org/r/512438

matmarex renamed this task from [regression] Editor is read-only after recovering autosaved changes to [regression] Editor is read-only after recovering autosaved changes or switching VE to NWE.May 24 2019, 9:19 PM

Looks like this made it into wmf.6… :/ we should backport on Monday.

matmarex triaged this task as Unbreak Now! priority.May 24 2019, 9:21 PM
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptMay 24 2019, 9:21 PM

Change 512438 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Store 'canEdit' property when auto-saving or switching editors

https://gerrit.wikimedia.org/r/512438

Change 512448 had a related patch set uploaded (by Jforrester; owner: Bartosz Dziewoński):
[mediawiki/extensions/VisualEditor@wmf/1.34.0-wmf.6] Store 'canEdit' property when auto-saving or switching editors

https://gerrit.wikimedia.org/r/512448

Change 512448 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@wmf/1.34.0-wmf.6] Store 'canEdit' property when auto-saving or switching editors

https://gerrit.wikimedia.org/r/512448

Mentioned in SAL (#wikimedia-operations) [2019-05-25T00:30:20Z] <jforrester@deploy1001> Synchronized php-1.34.0-wmf.6/extensions/VisualEditor/modules/ve-mw/init/ve.init.mw.ArticleTarget.js: Hot-deploy T224319 for VisualEditor switching and auto-restore (duration: 00m 50s)

Jdforrester-WMF lowered the priority of this task from Unbreak Now! to High.May 25 2019, 1:50 AM
ppelberg closed this task as Resolved.Jul 3 2019, 3:11 AM