Page MenuHomePhabricator

`scap sync` fails with CalledProcessError
Closed, ResolvedPublic

Description

Terminal output

1zfilipin@deploy1001:/srv/mediawiki-staging$ scap sync "testwiki to php-1.34.0-wmf.7 and rebuild l10n cache"
2 ___ ____
3 ⎛ ⎛ ,----
4 \ //==--'
5 _//|,.·//==--' ____________________________
6 _OO≣=- ︶ ᴹw ⎞_§ ______ ___\ ___\ ,\__ \/ __ \
7 (∞)_, ) ( | ______/__ \/ /__ / /_/ / /_/ /
8 ¨--¨|| |- ( / ______\____/ \___/ \__^_/ .__/
9 ««_/ «_/ jgs/bd808 /_/
10
1110:51:19 Checking for new runtime errors locally
1210:51:19 Started scap: testwiki to php-1.34.0-wmf.7 and rebuild l10n cache
1310:51:20 Copying from deploy1001.eqiad.wmnet to deploy1001.eqiad.wmnet
1410:51:20 Started rsync common
1510:51:25 Finished rsync common (duration: 00m 04s)
1610:51:25 Started cache_git_info
1710:51:37 Finished cache_git_info (duration: 00m 12s)
1810:51:38 Started l10n-update
1910:51:38 Updating ExtensionMessages-1.34.0-wmf.6.php
2010:51:38 Updating LocalisationCache for 1.34.0-wmf.6 using 30 thread(s)
2110:53:33 Generating JSON versions and md5 files
2210:54:19 Creating empty /srv/mediawiki-staging/wmf-config/ExtensionMessages-1.34.0-wmf.7.php
2310:54:19 Bootstrapping l10n cache for 1.34.0-wmf.7
2410:54:19 Last output:
25A copy of your installation's LocalSettings.php
26must exist and be readable in the source directory.
27Use --conf to specify it.
2810:54:19 Finished l10n-update (duration: 02m 41s)
2910:54:19 Unhandled error:
30Traceback (most recent call last):
31 File "/usr/lib/python2.7/dist-packages/scap/cli.py", line 342, in run
32 exit_status = app.main(app.extra_arguments)
33 File "/usr/lib/python2.7/dist-packages/scap/main.py", line 603, in main
34 return super(Scap, self).main(*extra_args)
35 File "/usr/lib/python2.7/dist-packages/scap/main.py", line 85, in main
36 self._after_sync_common()
37 File "/usr/lib/python2.7/dist-packages/scap/main.py", line 626, in _after_sync_common
38 version, wikidb, self.verbose, self.config)
39 File "/usr/lib/python2.7/dist-packages/scap/utils.py", line 402, in context_wrapper
40 return func(*args, **kwargs)
41 File "/usr/lib/python2.7/dist-packages/scap/tasks.py", line 592, in update_localization_cache
42 wikidb, cache_dir, use_cores, lang='en', quiet=True)
43 File "/usr/lib/python2.7/dist-packages/scap/tasks.py", line 543, in _call_rebuildLocalisationCache
44 'quiet': '--quiet' if quiet else ''
45 File "/usr/lib/python2.7/dist-packages/scap/utils.py", line 402, in context_wrapper
46 return func(*args, **kwargs)
47 File "/usr/lib/python2.7/dist-packages/scap/utils.py", line 497, in sudo_check_call
48 raise subprocess.CalledProcessError(proc.returncode, cmd)
49CalledProcessError: Command '/usr/local/bin/mwscript rebuildLocalisationCache.php --wiki="testwiki" --outdir="/tmp/scap_l10n_4182265560" --threads=30 --lang en --quiet' returned non-zero exit status 1
5010:54:19 scap failed: CalledProcessError Command '/usr/local/bin/mwscript rebuildLocalisationCache.php --wiki="testwiki" --outdir="/tmp/scap_l10n_4182265560" --threads=30 --lang en --quiet' returned non-zero exit status 1 (duration: 03m 00s)

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 28 2019, 10:58 AM
zeljkofilipin triaged this task as Unbreak Now! priority.May 28 2019, 10:58 AM
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptMay 28 2019, 10:58 AM
hashar added a subscriber: hashar.May 28 2019, 11:22 AM

Caused by T224453?

That was git submodule update failing due to Gerrit being restarted.

Your task is rebuildLocalisationCache.php failing after 3 minutes.

Look at scap logs in logstash? Or scap --verbose sync

Tarrow added a subscriber: Tarrow.May 28 2019, 1:18 PM
zeljkofilipin closed this task as Resolved.May 28 2019, 2:13 PM
zeljkofilipin assigned this task to thcipriani.
zeljkofilipin added a subscriber: thcipriani.

Caused by T224453.

Fixed by (thanks to @thcipriani ):

cd /srv/mediawiki-staging/
rm -rf php-1.34.0-wmf.7
scap prep 1.34.0-wmf.7