Page MenuHomePhabricator

[Bug] Animated banner changes layout on update
Closed, ResolvedPublic

Description

Steps to reproduce

  1. Visit a page with the new Wikimania banner.
  2. Wait a few seconds for the banner to update.

Expected results

  • Page content remains the same

Actual results

  • Page content shifts whenever the animation updates. This damages the reading experience.

Environments observed

  • Browser version: Chromium v74.0.3729.169
  • OS version: Ubuntu v19.04
  • Device model: Desktop
  • Device language: English

Check any additional observations

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 31 2019, 3:35 PM

Campaign currently only targetting logged in users but agree this is an issue.

I'd adjusted the english text lengths and I've made a further adjustment but I suspect this will still be an issue in other languages. I'll pull this banner down and put in a placeholder while I work on improvements to this design to reduce readability issues.

stjn added a subscriber: stjn.Jun 1 2019, 1:23 PM

This is the first banner in years that I’ve willingly closed. It not only shifts layout (they all do), but also flickers far too much for comfortable reading of articles (this, probably, has effects on people with motion sickness) and takes too much place in the layout in comparison with other banners. I am relieved, however, that it doesn’t get shown to readers.

Fixing this bug is impossible without getting rid of animation entirely, because every language has a different wording that can exceed your expectations, so I am asking you to consider it.

Discussion about it in Russian Wikipedia:
https://ru.wikipedia.org/wiki/Википедия:Форум/Общий#Ёрзанье_страниц

Pols12 awarded a token.Jun 1 2019, 9:38 PM
Pols12 added a subscriber: Pols12.Jun 1 2019, 9:47 PM

I agree with stjn: animation is really disturbing while reading.

WMF wikis shouldn’t contain autostarted infinite loop animation.

Thanks all for the feedback regarding this. The banner was pulled and we've returned to a standard format staggering the campaigns.

Just for insight into why this was trialled, in some instances we get overlapping campaigns and I'm trying to find ways we can handle overlapping campaigns in an efficient manner until we have a feature like campaign fallback in place (T124969).

There may be one usage of a style similar to this at the end of the month to alleviate a conflict between two community campaigns but right now it will be limited to a single instance and single language.

Since apologies to all communities for the disruption this caused.

Jseddon closed this task as Resolved.Jun 3 2019, 3:44 AM
Jseddon triaged this task as High priority.

Thanks for the speedy resolution, @Jseddon!