Page MenuHomePhabricator

Kartographer maps with external data from OSM only works sometimes for the same data
Closed, ResolvedPublic

Description

Sometimes Kartographer maps with external data from OSM works, and sometimes they don't work with the same data.

See https://da.wikipedia.org/w/index.php?title=Bruger:Dipsacus_fullonum/sandkasse&oldid=9957579 for an example.

The page have two Kartographer maps. Both should show the countries Bosnia and Hercegovina, Croatia, and Montenegro in different colors. The first map have the Wikidata ID's explicit in the JSON code. The second map get them from a trivial SPARQL query.

The first map with the explicit ID's is shown correct in the page, but the second map with the SPARQL query is not shown at all.

But if I start editing the page and make a preview then in the first map only Croatia is filled with colour while the two other countries are missing, but now the second map now is shown correct with all 3 countries filled with colour.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 2 2019, 10:27 PM

The first map with the explicit ID's is shown correct in the page, but the second map with the SPARQL query is not shown at all.

Cannot reproduce. It is shown for me on https://da.wikipedia.org/w/index.php?title=Bruger:Dipsacus_fullonum/sandkasse&oldid=9957579

@Dipsacus_fullonum: If it is not shown, what is there instead? Can you take a look at the source of that HTML page?

Dipsacus_fullonum added a comment.EditedJun 3 2019, 10:05 AM

@Aklapper: Now the second map with the SPARQL query is also correct for me. But when the page was created it was only shown as a frame with the legend, but where the map should be, there was only a white empty space.

When I press "Edit" and then "Show preview", now the preview of both maps are missing 2 of the 3 countries (Bosnia and Hercegovina, and Montrenegro). Before it was only the first map, while the second was correct in the preview.

Pikne added a subscriber: Pikne.Jun 3 2019, 10:47 AM

Missing country polygons on dynamic map (page preview) seem to be be related to T218097.

While different behaviour for these two maps seem to be due to T214984. With PHP7 the second map with SPARQL query gives "Couldn't parse JSON" error and with HHVM both maps work. On da.wikipedia.org I currently get HHVM as a logged-in user and if I log out I get PHP7.

Things keep changing. At the same page (https://da.wikipedia.org/w/index.php?title=Bruger:Dipsacus_fullonum/sandkasse&oldid=9957579) now the first map, with Wikidata ID's explicit in the JSON code, only show the geoshape for Croatia.

The second map with the SPARQL query now only shows the frame, the legend, the copyright message, and the button for an interactive fullscreen button, but no map at all. When the button is pressed, I get a interactive map with only Croatia marked.

MSantos closed this task as Resolved.Jun 25 2019, 4:00 PM
MSantos claimed this task.
MSantos added a subscriber: MSantos.